<!DOCTYPE html>
<!--[if lt IE 7]>      <html class="no-js lt-ie9 lt-ie8 lt-ie7"> <![endif]-->
<!--[if IE 7]>         <html class="no-js lt-ie9 lt-ie8"> <![endif]-->
<!--[if IE 8]>         <html class="no-js lt-ie9"> <![endif]-->
<!--[if gt IE 8]><!--> <html class="no-js"> <!--<![endif]-->
    <head>
				<link href='https://fonts.googleapis.com/css?family=Lora:400,400italic,700,700italic|Lato:400,700,900,400italic,700italic,900italic' rel='stylesheet' type='text/css'>
        <meta charset="utf-8">
        <meta http-equiv="X-UA-Compatible" content="IE=edge,chrome=1">
				<title>Victim of former NFL player&#039;s rampage wrote of faith, life&#039;s fragility - Salisbury Post | Salisbury Post</title>

								<script type="text/javascript">
					<!--
					if (screen.availWidth && screen.availWidth < 481) {
							//Conditional script here
              window.location.href = "https://" + "m.salisburypost.com" + window.location.pathname 
					}
					//-->
				</script>

        
								<link rel="stylesheet" type="text/css" media="screen" href="https://www.salisburypost.com/wp-content/themes/2016-bni/media/js/vendor/jquery.bxslider/jquery.bxslider.css?1592988658" />
				<link rel="stylesheet" href="https://www.salisburypost.com/wp-content/themes/2016-bni/media/css/normalize.css?1592988658" />
				<link rel="stylesheet" href="https://www.salisburypost.com/wp-content/themes/2016-bni/media/css/base.css?1614980832" />
				<link rel="stylesheet" type="text/css" media="screen" href="https://www.salisburypost.com/wp-content/themes/2016-bni/style.css?1597348382" />

        <script src="https://www.salisburypost.com/wp-content/themes/2016-bni/media/js/vendor/modernizr-2.6.2.min.js?1592988658"></script>

				<link rel="Shortcut Icon" type="image/ico" href="https://www.salisburypost.com/wp-content/themes/2016-salisbury-child/media/img/brand/favicon-salisburypost.png">

				
																<meta name='robots' content='max-image-preview:large' />

	<!-- This site is optimized with the Yoast SEO plugin v15.5 - https://yoast.com/wordpress/plugins/seo/ -->
	<meta name="robots" content="index, follow, max-snippet:-1, max-image-preview:large, max-video-preview:-1" />
	<link rel="canonical" href="https://www.salisburypost.com/2021/04/09/victim-of-former-nfl-players-rampage-wrote-of-faith-lifes-fragility/" />
	<meta property="og:locale" content="en_US" />
	<meta property="og:type" content="article" />
	<meta property="og:title" content="Victim of former NFL player&#039;s rampage wrote of faith, life&#039;s fragility - Salisbury Post" />
	<meta property="og:description" content="By MEG KINNARD Associated Press COLUMBIA, S.C. (AP) — Robert Lesslie, the South Carolina physician and author who authorities say was killed along with three family members and a repairman by former NFL player Phillip Adams, frequently wrote of the fragility of life and a deep-seated Christian faith that guided him personally and professionally. &#8220;I [&hellip;]" />
	<meta property="og:url" content="https://www.salisburypost.com/2021/04/09/victim-of-former-nfl-players-rampage-wrote-of-faith-lifes-fragility/" />
	<meta property="og:site_name" content="Salisbury Post" />
	<meta property="article:published_time" content="2021-04-09T04:00:04+00:00" />
	<meta property="article:modified_time" content="2021-04-09T04:17:24+00:00" />
	<meta property="og:image" content="https://salisburypost.com/wp-content/uploads/sites/9/2020/07/weblogo-national.jpg" />
	<meta property="og:image:width" content="622" />
	<meta property="og:image:height" content="352" />
	<meta name="twitter:card" content="summary_large_image" />
	<meta name="twitter:label1" content="Written by">
	<meta name="twitter:data1" content="News Service Report">
	<meta name="twitter:label2" content="Est. reading time">
	<meta name="twitter:data2" content="5 minutes">
	<script type="application/ld+json" class="yoast-schema-graph">{"@context":"https://schema.org","@graph":[{"@type":"WebSite","@id":"https://www.salisburypost.com/#website","url":"https://www.salisburypost.com/","name":"Salisbury Post","description":"News from Salisbury, North Carolina","potentialAction":[{"@type":"SearchAction","target":"https://www.salisburypost.com/?s={search_term_string}","query-input":"required name=search_term_string"}],"inLanguage":"en-US"},{"@type":"ImageObject","@id":"https://www.salisburypost.com/2021/04/09/victim-of-former-nfl-players-rampage-wrote-of-faith-lifes-fragility/#primaryimage","inLanguage":"en-US","url":"https://salisburypost.com/wp-content/uploads/sites/9/2020/07/weblogo-national.jpg","width":622,"height":352},{"@type":"WebPage","@id":"https://www.salisburypost.com/2021/04/09/victim-of-former-nfl-players-rampage-wrote-of-faith-lifes-fragility/#webpage","url":"https://www.salisburypost.com/2021/04/09/victim-of-former-nfl-players-rampage-wrote-of-faith-lifes-fragility/","name":"Victim of former NFL player's rampage wrote of faith, life's fragility - Salisbury Post","isPartOf":{"@id":"https://www.salisburypost.com/#website"},"primaryImageOfPage":{"@id":"https://www.salisburypost.com/2021/04/09/victim-of-former-nfl-players-rampage-wrote-of-faith-lifes-fragility/#primaryimage"},"datePublished":"2021-04-09T04:00:04+00:00","dateModified":"2021-04-09T04:17:24+00:00","author":{"@id":"https://www.salisburypost.com/#/schema/person/fae9254009f519b8325842a582708449"},"inLanguage":"en-US","potentialAction":[{"@type":"ReadAction","target":["https://www.salisburypost.com/2021/04/09/victim-of-former-nfl-players-rampage-wrote-of-faith-lifes-fragility/"]}]},{"@type":"Person","@id":"https://www.salisburypost.com/#/schema/person/fae9254009f519b8325842a582708449","name":"News Service Report","image":{"@type":"ImageObject","@id":"https://www.salisburypost.com/#personlogo","inLanguage":"en-US","url":"https://secure.gravatar.com/avatar/012fbe6324f0f9ffc6c824c9ed4fc04c?s=96&d=mm&r=g","caption":"News Service Report"}}]}</script>
	<!-- / Yoast SEO plugin. -->


<link rel='dns-prefetch' href='//www.salisburypost.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="Salisbury Post &raquo; Victim of former NFL player&#8217;s rampage wrote of faith, life&#8217;s fragility Comments Feed" href="https://salisburypost.com/2021/04/09/victim-of-former-nfl-players-rampage-wrote-of-faith-lifes-fragility/feed/" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.0.1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.0.1\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/salisburypost.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.7"}};
			!function(e,a,t){var n,r,o,i=a.createElement("canvas"),p=i.getContext&&i.getContext("2d");function s(e,t){var a=String.fromCharCode;p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,e),0,0);e=i.toDataURL();return p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,t),0,0),e===i.toDataURL()}function c(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(o=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},r=0;r<o.length;r++)t.supports[o[r]]=function(e){if(!p||!p.fillText)return!1;switch(p.textBaseline="top",p.font="600 32px Arial",e){case"flag":return s([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])?!1:!s([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!s([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]);case"emoji":return!s([55357,56424,8205,55356,57212],[55357,56424,8203,55356,57212])}return!1}(o[r]),t.supports.everything=t.supports.everything&&t.supports[o[r]],"flag"!==o[r]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[o[r]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(n=t.source||{}).concatemoji?c(n.concatemoji):n.wpemoji&&n.twemoji&&(c(n.twemoji),c(n.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel='stylesheet' id='all-css-0' href='https://salisburypost.com/_static/??-eJxljNEKQEAQRX8I05ItD/ItdmwZO7srs8LfkyLl7Xbu6cA25xSQ18EKoAgMvYyEMUjhKRQXyeCrTALp+p2J+zv+1h0iSWA4osuZzNIvB0g62D7dzrdKq7oqVd3oE26WMPw=' type='text/css' media='all' />
<style id='wp-block-library-inline-css'>
.has-text-align-justify{text-align:justify;}
</style>
<link rel='stylesheet' id='mpp_gutenberg-css'  href='https://www.salisburypost.com/wp-content/plugins/metronet-profile-picture/dist/blocks.style.build.css?ver=2.3.6' media='all' />
<link rel='stylesheet' id='m1mw-css'  href='https://www.salisburypost.com/wp-content/plugins/m1miniweather-bni-.0.2.b/css/weather-icons.min.css?ver=5.7' media='all' />
<link rel='stylesheet' id='all-css-4' href='https://salisburypost.com/wp-includes/css/admin-bar.min.css?m=1615321595g' type='text/css' media='all' />
<style id='admin-bar-inline-css'>
#wp-admin-bar-my-sites-search.hide-if-no-js {
	display: none;
}
#wp-admin-bar-my-sites-search label[for="my-sites-search-text"] {
	clip: rect(1px, 1px, 1px, 1px);
	position: absolute !important;
	height: 1px;
	width: 1px;
	overflow: hidden;
}
#wp-admin-bar-my-sites-search {
	height: 38px;
}
#wp-admin-bar-my-sites-search .ab-item {
	height: 34px;
}
#wp-admin-bar-my-sites-search input {
	padding: 0 2px;
	width: 95%;
	width: calc( 100% - 4px );
}
	
</style>
<link rel='stylesheet' id='wp-polls-css'  href='https://www.salisburypost.com/wp-content/plugins/wp-polls/polls-css.css?ver=2.75.3' media='all' />
<style id='wp-polls-inline-css'>
.wp-polls .pollbar {
	margin: 1px;
	font-size: 6px;
	line-height: 8px;
	height: 8px;
	background-image: url('https://www.salisburypost.com/wp-content/plugins/wp-polls/images/default/pollbg.gif');
	border: 1px solid #c8c8c8;
}

</style>
<link rel='stylesheet' id='simple-staff-list-css'  href='https://www.salisburypost.com/wp-content/plugins/simple-staff-list/public/css/simple-staff-list-public.css?ver=2.2.0' media='all' />
<link rel='stylesheet' id='parent-style-css'  href='https://www.salisburypost.com/wp-content/themes/2016-bni/style.css?ver=5.7' media='all' />
<link rel='stylesheet' id='child-style-css'  href='https://www.salisburypost.com/wp-content/themes/2016-salisbury-child/style.css?ver=1614954867' media='all' />
<link rel='stylesheet' id='jetpack_css-css'  href='https://www.salisburypost.com/wp-content/mu-plugins/jetpack-9.6/css/jetpack.css?ver=9.6' media='all' />
<script type='text/javascript' src='https://salisburypost.com/_static/??-eJzTLy/QzcxLzilNSS3WzwKiwtLUokoopZebmaeXVayjj0+Rbm5melFiSSpUsX2uraGZoamxkaGppVkWAK9SIh8='></script>
<link rel="https://api.w.org/" href="https://salisburypost.com/wp-json/" /><link rel="alternate" type="application/json" href="https://salisburypost.com/wp-json/wp/v2/posts/503395" /><link rel='shortlink' href='https://salisburypost.com/?p=503395' />
<link rel="alternate" type="application/json+oembed" href="https://salisburypost.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fsalisburypost.com%2F2021%2F04%2F09%2Fvictim-of-former-nfl-players-rampage-wrote-of-faith-lifes-fragility%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://salisburypost.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fsalisburypost.com%2F2021%2F04%2F09%2Fvictim-of-former-nfl-players-rampage-wrote-of-faith-lifes-fragility%2F&#038;format=xml" />
<link href="https://trinitymedia.ai" rel="preconnect" crossorigin="anonymous" />
<link href="https://vd.trinitymedia.ai" rel="preconnect" crossorigin="anonymous" />
<style type='text/css'>img#wpstats{display:none}</style>
		<!-- Global site tag (gtag.js) - Google Analytics -->
<script>
  (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
  (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
  m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
  })(window,document,'script','//www.google-analytics.com/analytics.js','ga');
  ga('create', 'UA-34177675-1', 'auto');
  ga('send', 'pageview');
</script>
											<script type="text/javascript">
					document.write(unescape("%3Cscript src='https://subscriptions.salisburypost.com/bwtw/scripts/tw.js' type='text/javascript'%3E%3C/script%3E"));
				</script>
				<script type="text/javascript">

					
					_bwtp = new TheWall('https://subscriptions.salisburypost.com/bwtw/', 'SP', 'SP', null, 'DEFAULT');

          var pw_total_val = '0';
          var pw_read_val = '0';

					_bwtp.init();
          loggedin = _bwtp.userStatus();
          _bwtp.status(function(f) { 
            pw_total_val = f.viewRate.AllowedViews;
            pw_read_val = f.viewRate.NumViews;
          });

					jQuery(window).load(function() { // These functions get called when everything has loaded
						if (!loggedin) {
							jQuery("#supNav").append('<li><a href="#" onclick="_bwtp.Auth(true);">Log In</a></li>');
              if (( pw_total_val > 0 ) && ( pw_read_val <= pw_total_val ) && ( jQuery('body').attr("id") != "homePage")) {
                var paywall_info_content = '<div id="paywall_info_box" style="padding: 1em 0; margin: 1em 0; font-weight: bold; border-top: 1px solid #aaa; border-bottom: 1px solid #aaa; text-align: center; color: #222;">' +
                  '<p style="font-weight: bold;">You have read ' + pw_read_val + ' of ' + pw_total_val + ' articles.</p>' +
                  '<p style="margin-bottom: 0; font-weight: bold;"><a href="#" onclick="_bwtp.Auth(true);" style="color: #92191f;">Log In or Subscribe</a></p>' + 
                  '</div>';
                jQuery(paywall_info_content).appendTo('div#article div.byline').fadeIn();
              }

						} else {
							jQuery("#supNav").append('<li><a href="#" onclick="_bwtp.clearID();">Log Out</a></li>');
						}
					});
				</script>


				<script type="text/javascript" src="https://www.salisburypost.com/wp-content/themes/2016-bni/media/js/colorbox/jquery.colorbox-min.js"></script>
				<link rel="stylesheet" type="text/css" media="screen" href="https://www.salisburypost.com/wp-content/themes/2016-bni/media/js/colorbox/colorbox.css" />

        <script type="text/javascript">!(function(o,n,t){t=o.createElement(n),o=o.getElementsByTagName(n)[0],t.async=1,t.src="https://gondolagnome.com/v2/0/qgm--t1cSnkJXHwvoo7JKXT4-fniaL7GoKdYaAHjVpaT3LGQD-2yOxsw17xqTxCsa1eU6UZ1N43JR0",o.parentNode.insertBefore(t,o)})(document,"script"),(function(o,n){o[n]=o[n]||function(){(o[n].q=o[n].q||[]).push(arguments)}})(window,"admiral");!(function(n,e,r,t){function o(){if((function o(t){try{return(t=localStorage.getItem("v4ac1eiZr0"))&&0<t.split(",")[4]}catch(n){}return!1})()){var t=n[e].pubads();typeof t.setTargeting===r&&t.setTargeting("admiral-engaged","true")}}(t=n[e]=n[e]||{}).cmd=t.cmd||[],typeof t.pubads===r?o():typeof t.cmd.unshift===r?t.cmd.unshift(o):t.cmd.push(o)})(window,"googletag","function");;;;;</script>

<script async src="https://sync.serverbid.com/ss/2000707.js"></script>


<meta property="fb:app_id" content="168913723140235" />
				
<script async src="//js-sec.indexww.com/ht/p/188239-192868292012837.js"></script>
<script id="optimera-ops" src="https://d15kdpgjg3unno.cloudfront.net/oPS.js?cid=57" data-cid="57"></script>


<!-- DFP Work -->

    <script src='https://www.googletagservices.com/tag/js/gpt.js'></script>


<script>
  var googletag = googletag || {};
  googletag.cmd = googletag.cmd || [];
</script>


<script>

googletag.cmd.push(function() {

    			googletag.defineSlot('/1613683/SNL-160x600-1', [160, 600], 'div-gpt-ad-skyscraper').addService(googletag.pubads());
			googletag.defineSlot('/1613683/SNL-300x250-16', [300, 250], 'div-gpt-ad-instory-top').addService(googletag.pubads());
			googletag.defineSlot('/1613683/SNL-300x250-17', [300, 250], 'div-gpt-ad-instory-bottom').addService(googletag.pubads());
			googletag.defineSlot('/1613683/SNL-300x250-instory-third', [[300, 250], [1, 1]], 'div-gpt-ad-instory-third').addService(googletag.pubads());
			FEATUREDGALLERY_AD = googletag.defineSlot('/1613683/SNL-300x250-featured_gallery', [300, 250], 'div-gpt-ad-bigblock-featured_gallery').addService(googletag.pubads());

  if (!loggedin) {
			googletag.defineSlot('/1613683/SNL-1x1-2', [1,1], 'div-gpt-ad-extra_one_by_one').addService(googletag.pubads());
			googletag.defineSlot('/1613683/SNL-1x1-3', [1,1], 'div-gpt-ad-extra_oop').addService(googletag.pubads());
			googletag.defineSlot('/1613683/SNL-1x1-4', [1,1], 'div-gpt-ad-extra_one_by_one_two').addService(googletag.pubads());
  }

    			googletag.defineSlot('/1613683/SNL-300x100-1', [300, 100], 'div-gpt-ad-skybox').addService(googletag.pubads());
			googletag.defineSlot('/1613683/SNL-300x250-1', [[300, 600], [300, 250]], 'div-gpt-ad-bigblock-1').addService(googletag.pubads());
			googletag.defineSlot('/1613683/SNL-300x250-2', [[300, 600], [300, 250]], 'div-gpt-ad-bigblock-2').addService(googletag.pubads());
			googletag.defineSlot('/1613683/SNL-300x250-3', [[300, 600], [300, 250]], 'div-gpt-ad-bigblock-3').addService(googletag.pubads());

			googletag.defineSlot('/1613683/SNL-300x600-1', [[300, 600], [160, 600]], 'div-gpt-ad-halfpage-1').addService(googletag.pubads());
			googletag.defineSlot('/1613683/SNL-970x90-1', [[970, 90], [970, 250], [728, 90]], 'div-gpt-ad-largeleaderboard').addService(googletag.pubads());
			googletag.defineSlot('/1613683/SNL-1x1-duration', [1,1], 'div-gpt-ad-one_by_one_duration').addService(googletag.pubads());

  if (!loggedin) {
			googletag.defineSlot('/1613683/SNL-300x250-18', [300, 250], 'div-gpt-ad-bigblock-18').addService(googletag.pubads());
			googletag.defineSlot('/1613683/SNL-1x1-wall', [1,1], 'div-gpt-ad-one_by_one_wall').addService(googletag.pubads());
			googletag.defineOutOfPageSlot('/1613683/SNL-1x1-1', 'div-gpt-ad-screenshift').addService(googletag.pubads());
  }


                  googletag.pubads().setTargeting("catname", [ "usworld", "news", "wire",  ]);
                


          googletag.pubads().setTargeting("pageurl", "/2021/04/09/victim-of-former-nfl-players");
    
      // TESTING 1.1
    // Lazy Load settings
    googletag.pubads().enableLazyLoad({
      fetchMarginPercent: 2,  // Fetch slots within .02 viewports.
      renderMarginPercent: 1,  // Render slots within .01 viewports.
      mobileScaling: 0  // same value on mobile.
    });
    
		googletag.pubads().enableSingleRequest();
		//googletag.pubads().collapseEmptyDivs()
    googletag.pubads().disableInitialLoad();
    googletag.enableServices();

});
</script>




<script>
//load the apstag.js library
!function(a9,a,p,s,t,A,g){if(a[a9])return;function q(c,r){a[a9]._Q.push([c,r])}a[a9]={init:function(){q("i",arguments)},fetchBids:function(){q("f",arguments)},setDisplayBids:function(){},targetingKeys:function(){return[]},_Q:[]};A=p.createElement(s);A.async=!0;A.src=t;g=p.getElementsByTagName(s)[0];g.parentNode.insertBefore(A,g)}("apstag",window,document,"script","//c.amazon-adsystem.com/aax2/apstag.js");

//initialize the apstag.js library on the page to allow bidding
apstag.init({
     pubID:  '26673ab7-6c90-4748-8b4c-71512dcf8ef3', //enter your pub ID here as shown above, it must within quotes
     adServer: 'googletag'
});
apstag.fetchBids({
     slots: [{
          slotID: 'div-gpt-ad-skyscraper',
          slotName: '1613683/SNL-160x600-1',
          sizes: [[160, 600]]
      },
      //{
          //slotID: 'div-gpt-ad-skybox',
          //slotName: '1613683/SNL-300x100-1',
          //sizes: [[300, 100]]
      //},
      //{
          //slotID: 'div-gpt-ad-threesix-1',
          //slotName: '1613683/SNL-300x600-1',
          //sizes: [[300, 600]]
      //},
      {
          slotID: 'div-gpt-ad-bigblock-1',
          slotName: '1613683/SNL-300x250-1',
          sizes: [[300, 600], [300, 250]]
      },
      {
          slotID: 'div-gpt-ad-bigblock-2',
          slotName: '1613683/SNL-300x250-2',
          sizes: [[300, 600], [300, 250]]
      },
			{
					slotID: 'div-gpt-ad-bigblock-3',
					slotName: '1613683/SNL-300x250-3',
					sizes: [[300, 600], [300, 250]]
			},
      {
          slotID: 'div-gpt-ad-bigblock-4',
          slotName: '1613683/SNL-300x250-4',
          sizes: [[300, 250]]
      },
      {
          slotID: 'div-gpt-ad-bigblock-5',
          slotName: '1613683/SNL-300x250-5',
          sizes: [[300, 250]]
      },
			{
					slotID: 'div-gpt-ad-bigblock-6',
					slotName: '1613683/SNL-300x250-6',
					sizes: [[300, 250]]
			},
			{
					slotID: 'div-gpt-ad-bigblock-7',
					slotName: '1613683/SNL-300x250-7',
					sizes: [[300, 250]]
			},
			{
					slotID: 'div-gpt-ad-bigblock-8',
					slotName: '1613683/SNL-300x250-8',
					sizes: [[300, 250]]
			},
			{
					slotID: 'div-gpt-ad-bigblock-9',
					slotName: '1613683/SNL-300x250-9',
					sizes: [[300, 250]]
			},
			{
					slotID: 'div-gpt-ad-bigblock-10',
					slotName: '1613683/SNL-300x250-10',
					sizes: [[300, 250]]
			},
			{
					slotID: 'div-gpt-ad-bigblock-11',
					slotName: '1613683/SNL-300x250-11',
					sizes: [[300, 250]]
			},
			{
					slotID: 'div-gpt-ad-bigblock-12',
					slotName: '1613683/SNL-300x250-12',
					sizes: [[300, 250]]
			},
			{
					slotID: 'div-gpt-ad-bigblock-13',
					slotName: '1613683/SNL-300x250-13',
					sizes: [[300, 250]]
			},
			{
					slotID: 'div-gpt-ad-bigblock-14',
					slotName: '1613683/SNL-300x250-14',
					sizes: [[300, 250]]
			},
			{
					slotID: 'div-gpt-ad-bigblock-15',
					slotName: '1613683/SNL-300x250-15',
					sizes: [[300, 250]]
			},
      {
          slotID: 'div-gpt-ad-instory-top',
          slotName: '1613683/SNL-300x250-16',
          sizes: [[300, 250]]
      },
      {
          slotID: 'div-gpt-ad-instory-bottom',
          slotName: '1613683/SNL-300x250-17',
          sizes: [[300, 250]]
      },
      //{
          //slotID: 'div-gpt-ad-bigblock-18',
          //slotName: '1613683/SNL-300x250-18',
          //sizes: [[300, 250]]
      //},
      //{
          //slotID: 'div-gpt-ad-instory-third',
          //slotName: '1613683/SNL-300x250-instory-third',
          //sizes: [[300, 250]]
      //},
      {
          slotID: 'div-gpt-ad-mobile-sticky',
          slotName: '1613683/SNL-320x50-1',
          sizes: [[320, 50], [1, 1]]
      },
      {
          slotID: 'div-gpt-ad-largeleaderboard',
          slotName: '1613683/SNL-970x90-1',
          sizes: [[970, 90], [728, 90], [970, 250]]
     }],
     timeout: 2e3
}, function(bids) {
     // set apstag targeting on googletag, then trigger the first DFP request in googletag's disableInitialLoad integration
     googletag.cmd.push(function(){
         apstag.setDisplayBids();
				 googletag.pubads().refresh();
     });
}); 
</script>


<script>
   var otkjs = otkjs || {};
    /**
     * Add any divs to refresh.
     * 
     * Parameters:
     * 1. Array of divs w/parameter to refresh, can be one or many:
     *  - DIV_ID: The DOM div id of the ad position
     *  - MIN_TIME_IN_VIEW: The amount of time the ad must be 
     *      in view before being eligible to be refreshed, we recommend at least 1.1 seconds
     *  - MIN_TIME_ON_PAGE: The amount of time the ad must be in von the page before refreshing 
     *  - TARGETING: Array of key/value targeting for the ad slot.
     * 
     * NOTE: The ad will on refresh once the parameters are met and the ad is
     * is currently in view.
     * 
     * Function:
     * otkjs.addRefresh(
     * Array[
     *    Array[DIV_ID, MIN_TIME_IN_VIEW, MIN_TIME_ON_PAGE, TARGETING[Array['key', 'value']]
     * ]);
     * 
     * Example - add two ad divs to be refreshed:
     *   otkjs.addRefresh([
     *     ['div-1', 1.1, 30, [['key2', 'value2'], ['refresh', 'true']]],
     *     ['div-2', 1.1, 30, [['key4', 'value4'], ['refresh', 'true']]]
     *   ]);
     */
      var mt_in_view = 1.2
      var mt_on_page = 34

      otkjs.addRefresh([
        //['div-1', mt_in_view, mt_on_page, [['refresh', 'true']]]
            ['div-gpt-ad-skyscraper', mt_in_view, mt_on_page, [['refresh', 'true']]],
        ['div-gpt-ad-instory-top', mt_in_view, mt_on_page, [['refresh', 'true']]],
        ['div-gpt-ad-instory-bottom', mt_in_view, mt_on_page, [['refresh', 'true']]],
        ['div-gpt-ad-instory-third', mt_in_view, mt_on_page, [['refresh', 'true']]],
        ['div-gpt-ad-extra_one_by_one', mt_in_view, mt_on_page, [['refresh', 'true']]],
        ['div-gpt-ad-extra_oop', mt_in_view, mt_on_page, [['refresh', 'true']]],
        ['div-gpt-ad-extra_one_by_one_two', mt_in_view, mt_on_page, [['refresh', 'true']]],
            ['div-gpt-ad-skybox', mt_in_view, mt_on_page, [['refresh', 'true']]],
        ['div-gpt-ad-bigblock-1', mt_in_view, mt_on_page, [['refresh', 'true']]],
        ['div-gpt-ad-bigblock-2', mt_in_view, mt_on_page, [['refresh', 'true']]],
        ['div-gpt-ad-bigblock-3', mt_in_view, mt_on_page, [['refresh', 'true']]],
        ['div-gpt-ad-halfpage-1', mt_in_view, mt_on_page, [['refresh', 'true']]],
        ['div-gpt-ad-largeleaderboard', mt_in_view, mt_on_page, [['refresh', 'true']]],
        ['div-gpt-ad-one_by_one_wall', mt_in_view, mt_on_page, [['refresh', 'true']]],
        ['div-gpt-ad-screenshift', mt_in_view, mt_on_page, [['refresh', 'true']]]
      ]);
  </script>

                        <script type="text/javascript" src="//s.ntv.io/serve/load.js" async></script>
        

    </head>
		<body id="articlePage">
        <!--[if lt IE 7]>
            <p class="chromeframe">You are using an <strong>outdated</strong> browser. Please <a href="http://browsehappy.com/">upgrade your browser</a> or <a href="http://www.google.com/chromeframe/?redirect=true">activate Google Chrome Frame</a> to improve your experience.</p>
        <![endif]-->
        																<!-- Paste this after your <body> tag. Fill in "ARTICLE_URL" and "CONTENT_ID" --> 
				<script type="text/javascript"> 
				(function() { 
					var ARTICLE_URL = 'https://salisburypost.com/2021/04/09/victim-of-former-nfl-players-rampage-wrote-of-faith-lifes-fragility/'; 
					var CONTENT_ID = ''; // Optional or leave empty 
					document.write( 
						'<scr'+'ipt '+ 
						'src="//survey.g.doubleclick.net/survey?site=_acby66y5aly33aqou3rkicnpnu'+ 
						'&amp;url='+encodeURIComponent(ARTICLE_URL)+ 
						(CONTENT_ID ? '&amp;cid='+encodeURIComponent(CONTENT_ID) : '')+ 
						'&amp;random='+(new Date).getTime()+ 
						'" type="text/javascript">'+'\x3C/scr'+'ipt>'); 
          })(); 

          jQuery(document).ready(function() { // These functions get called on DOM ready
						if (!loggedin) {
							load_402_show_function();
						}
          });
				</script> 
				

				<div id="" class="undertone">


					<!-- Add your site or application content here -->

          <div id="sup_nav" class="sup_nav">

						<div class="ad large_leaderboard">
							<div class="ad970x90 large_leaderboard"><!-- ROS_970x90 -->
<div id='div-gpt-ad-largeleaderboard'>
  <script>
    googletag.cmd.push(function() { googletag.display('div-gpt-ad-largeleaderboard'); });
  </script>
</div></div>
						</div>

						<div class="wrapper">
							<ul id="supNav">
	<li class="public_notices"><a href="https://marketplace.salisburypost.com/AdHunter/SalisburyPost/Home/Search?majorClass=2600">Public Notices</a></li>
	<li class="">
		<a href="https://salisburypost.com/customer-service/">Submit</a>
		<ul class="sub-nav">
			<li><a href="https://salisburypost.com/customer-service/">Contact Us</a></li>
			<li><a href="https://docs.google.com/forms/d/e/1FAIpQLSfYRDDgs1wEHwOar6avWhnT-NBuQmtB12wRBJNEekuTbtM7-g/viewform">Submit Obituary</a></li>
			<li><a href="https://salisburypost.com/services/submit-a-news-tip/">Submit a News Tip</a></li>
			<li><a href="https://salisburypost.com/services/submit-letter/">Letter to the Editor</a></li>
			<li><a href="http://marketplace.salisburypost.com/Salisbury/">Place a Classified Ad</a></li>
			<li><a href="mailto:sales@salisburypost.com">Place a Retail Ad</a></li>
			<li><a href="https://portal.cityspark.com/EventEntry/EventEntry/SalisburyPost">Submit Community Calendar Event</a></li>
			<li><a href="https://salisburypost.com/celebrations-forms-and-info/">Celebrations Forms</a></li>
			<li><a href="https://salisburypost.com/submit-a-birthday/">Birthday Form</a></li>
			<li><a href="https://salisburypost.com/services/submit-a-birth-announcement/">Birth Announcement</a></li>
			<li><a href="https://salisburypost.com/services/submit-delays-or-closings/">Submit Delays or Closing</a></li>
			<li><a href="mailto:news@salisburypost.com">Submit a Correction</a></li>
		</ul>
	</li>
	<li class=""><a href="https://subscriptions.salisburypost.com/CircStore/Account/Login?vendor=DirXion&prodId=SP">E-edition</a></li>
	<li class=""><a href="https://salisburypost.com/insider">Email Sign-Up</a></li>
	<li class=""><a href="http://www.salisburypost.com/subscriptions/">Subscriptions</a></li>
	<li class=""><a href="http://www.salisburythemagazine.com/">SALISBURY the magazine</a></li>
  <li class="RoCo Gold"><a href="http://www.rocogold.com">RoCo Gold</a></li>    
	<li class=""><a href="https://salisburypost.com/special-sections/">Special Sections</a></li>
</ul>							<p class="date">
								April 9, 2021							</p>
							<div class="clearfix"></div>
						</div>
					</div>
					<div id="main_body" class="wrapper">

							
            						<header id="main_header">
							<div id="search_weather">
								<div id="weather">
									<div class="details">
										<ul>
											<li id="m1_miniweather_widget-3" class="widget widget_m1_miniweather_widget"><h2 class="widgettitle"></h2>
<div class="wi wi-owm-802" title="scattered clouds" style="font-size: 2em;">
			       <span class="m1mw_temp">75&deg;</span>
			     </div></li>
										</ul>
																				</div>
									<div class="clearfix"></div>
								</div>
								<div class="ad sponsorship">
										<!-- ROS_300x100_Skybox_Teaser -->
<div id='div-gpt-ad-skybox' style='height:100px; width:300px;'>
  <script>
    googletag.cmd.push(function() { googletag.display('div-gpt-ad-skybox'); });
  </script>
</div>								</div>
							</div>
            							<div id="logo">
								<a href="https://salisburypost.com">
									<img src="https://www.salisburypost.com/wp-content/themes/2016-salisbury-child/media/img/brand/logo-salisburypost.png" alt="Salisbury Post" />
								</a>
							</div>
							<div class="clearfix"></div>
							<nav id="navbar">
								<a href="https://salisburypost.com">
									<img class="logo" class="logo" src="https://www.salisburypost.com/wp-content/themes/2016-salisbury-child/media/img/brand/logo-salisburypost.png" alt="Salisbury Post" />
								</a>
								<ul id="mainNav">
	<li class="home "><a href="https://salisburypost.com">Home</a></li>
	<li class="news "><a href="https://salisburypost.com/category/news/">News</a>
		<!-- NEWS DROP -->
		<ul class="sub-nav">
			<li>
				<div class="contents">
					<div class="col first">
						<h3 class="section">In News</h3>
            <ul class="left">
                <li><a href="https://salisburypost.com/category/news/local/" title="Local News | Salisbury, North Carolina - The Salisbury Post">Local</a></li>
                <li><a href="https://salisburypost.com/category/business/" title="Business News | Salisbury, North Carolina - The Salisbury Post">Business</a></li>
                <li><a href="https://salisburypost.com/category/education/" title="Education News | Salisbury, North Carolina - The Salisbury Post">Education</a></li>
		<li><a href="https://salisburypost.com/category/grad/" title="Graduation | Rowan County, NC - The Salisbury Post">Graduation</a></li>
                <li><a href="https://salisburypost.com/category/trial/" title="Local Trial Coverage - The Salisbury Post">Trials</a></li>
                <li><a href="https://salisburypost.com/category/crime/" title="Crime | Salisbury, North Carolina - The Salisbury Post">Crime</a></li>
                <li><a href="https://salisburypost.com/category/lifestyle/" title="Lifestyle | Salisbury, North Carolina - The Salisbury Post">Lifestyle</a></li>
            </ul>
            <ul class="right">
		<li><a href="https://salisburypost.com/category/news/politics/" title="Politics | Salisbury, North Carolina - The Salisbury Post">Politics</a></li>
		<li><a href="https://salisburypost.com/category/news/spirit-of-rowan/" title="Spirit of Rowan | Salisbury, North Carolina - The Salisbury Post">Spirit of Rowan</a></li>
                <li><a href="https://salisburypost.com/category/news/kannapolis/" title="Kannapolis News | Salisbury, North Carolina - The Salisbury Post">Kannapolis</a></li>
                <li><a href="https://salisburypost.com/category/news/wineka/" title="Wineka | Salisbury, North Carolina - The Salisbury Post">Wineka</a></li>
                <li><a href="https://salisburypost.com/category/opinion/columns-opinion/" title="Columns | Salisbury, North Carolina - The Salisbury Post">Columns</a></li>
                <li><a href="https://salisburypost.com/category/usworld/" title="Nation/World | Salisbury, North Carolina - The Salisbury Post">Nation/World</a></li>
                <li class="Marketplace"><a href="https://www.youtube.com/user/salisburypostnc">Video</a></li>
            </ul>

					</div>
					<div class="col">
						<h3 class="section">Top News</h3>
												<div class="story">
														<a href="https://salisburypost.com/2021/04/09/spencer-town-board-gets-look-at-park-plaza-progress/" rel="bookmark">
								<img width="300" height="200" src="https://salisburypost.com/wp-content/uploads/sites/9/2021/04/0409-parkplaza-cb1.jpg?w=300" class="attachment-medium size-medium wp-post-image" alt="" loading="lazy" srcset="https://salisburypost.com/wp-content/uploads/sites/9/2021/04/0409-parkplaza-cb1.jpg 7360w, https://salisburypost.com/wp-content/uploads/sites/9/2021/04/0409-parkplaza-cb1.jpg?resize=300,200 300w, https://salisburypost.com/wp-content/uploads/sites/9/2021/04/0409-parkplaza-cb1.jpg?resize=768,513 768w, https://salisburypost.com/wp-content/uploads/sites/9/2021/04/0409-parkplaza-cb1.jpg?resize=1024,683 1024w, https://salisburypost.com/wp-content/uploads/sites/9/2021/04/0409-parkplaza-cb1.jpg?resize=1536,1025 1536w, https://salisburypost.com/wp-content/uploads/sites/9/2021/04/0409-parkplaza-cb1.jpg?resize=2048,1367 2048w, https://salisburypost.com/wp-content/uploads/sites/9/2021/04/0409-parkplaza-cb1.jpg?resize=622,415 622w, https://salisburypost.com/wp-content/uploads/sites/9/2021/04/0409-parkplaza-cb1.jpg?resize=524,350 524w" sizes="(max-width: 300px) 100vw, 300px" />							</a>
														<h3><a href="https://salisburypost.com/2021/04/09/spencer-town-board-gets-look-at-park-plaza-progress/" rel="bookmark" title="Spencer town board gets look at Park Plaza progress">Spencer town board gets look at Park Plaza progress</a></h3>										
							<h4 class="date">Friday, April 9, 2021 12:00 am</h4>
							<p>SPENCER — Town officials got their first look at progress on the inside of the Park Plaza project on Thursday. The project is moving along&nbsp;... 
								<span class="meta">
									<a href="https://salisburypost.com/2021/04/09/spencer-town-board-gets-look-at-park-plaza-progress/" class="noVisit readmore" rel="bookmark">Read&nbsp;more</a>
									| <a href="https://salisburypost.com/2021/04/09/spencer-town-board-gets-look-at-park-plaza-progress/#disqus_thread" class="noVisit comments" rel="bookmark">Add your comment</a>
								</span>
							</p>

						</div><!-- END STORY -->
											</div>
					<div class="col last">
						<h3 class="section">Latest News</h3>
												<div class="story">
							<h3><a href="https://salisburypost.com/2021/04/09/man-woman-charged-for-selling-drugs-to-undercover-deputies/" rel="bookmark" title="Man, woman charged for selling drugs to undercover deputies">Man, woman charged for selling drugs to undercover deputies</a></h3>										

						</div><!-- END STORY -->
												<div class="story">
							<h3><a href="https://salisburypost.com/2021/04/09/blotter-rowan-county-man-charged-with-indecent-liberties-with-children/" rel="bookmark" title="Blotter: Rowan County man charged with indecent liberties with children">Blotter: Rowan County man charged with indecent liberties with children</a></h3>										

						</div><!-- END STORY -->
												<div class="story">
							<h3><a href="https://salisburypost.com/2021/04/09/applicant-market-unemployment-rate-improving-as-businesses-hire-more-workers/" rel="bookmark" title="&#8216;Applicant market&#8217;: Unemployment rate improving as businesses hire more workers">&#8216;Applicant market&#8217;: Unemployment rate improving as businesses hire more workers</a></h3>										

						</div><!-- END STORY -->
												<div class="more_stories">
							<h4><a href="/category/news/">More News</a></h4>
						</div>
					</div>
				</div>
			</li>
		</ul>
		<!-- NEWS DROP END -->
	</li>
	<li class="coronavirus "><a href="https://salisburypost.com/category/news/coronavirus/">COVID19</a></li>
	<li class="sports"><a href="https://salisburypost.com/category/sports/">Sports</a>
		<!-- SPORTS DROP -->
		<ul class="sub-nav">
			<li>
				<div class="contents">
					<div class="col first">
						<h3 class="section">In Sports</h3>

            <ul class="left">
                <li><a href="https://salisburypost.com/category/sports/high-school/" title="High School Sports | Salisbury, North Carolina - The Salisbury Post">High School Sports</a></li>
                <li><a href="https://salisburypost.com/category/sports/college/" title="College Sports | Salisbury, North Carolina - The Salisbury Post">College Sports</a></li>
		<li><a href="http://collegebasketball.ap.org/salisburypost/" title="AP College Basketball News and Poll | Salisbury, North Carolina - The Salisbury Post">AP College BB News</a></li>    
		<li><a href="http://collegefootball.ap.org/salisburypost/" title="AP College Football News and Poll | Salisbury, North Carolina - The Salisbury Post">AP College FB News</a></li>
		<li><a href="http://pro32.ap.org/salisburypost/" title="AP Pro Football News and Poll | Salisbury, North Carolina - The Salisbury Post">AP Pro Football News</a></li>
		<li><a href="http://racing.ap.org/salisburypost/" title="AP NASCAR Home | Salisbury, North Carolina - The Salisbury Post">AP NASCAR Home</a></li>
             </ul>

					</div>
					<div class="col">
						<h3 class="section">Top Sports</h3>
												<div class="story">
														<a href="https://salisburypost.com/2021/04/06/high-school-football-broadway-making-plays/" rel="bookmark">
								<img width="300" height="220" src="https://salisburypost.com/wp-content/uploads/sites/9/2021/04/SALS.N-Davidson-Fball-13.jpg?w=300" class="attachment-medium size-medium wp-post-image" alt="" loading="lazy" srcset="https://salisburypost.com/wp-content/uploads/sites/9/2021/04/SALS.N-Davidson-Fball-13.jpg 700w, https://salisburypost.com/wp-content/uploads/sites/9/2021/04/SALS.N-Davidson-Fball-13.jpg?resize=300,220 300w, https://salisburypost.com/wp-content/uploads/sites/9/2021/04/SALS.N-Davidson-Fball-13.jpg?resize=622,457 622w, https://salisburypost.com/wp-content/uploads/sites/9/2021/04/SALS.N-Davidson-Fball-13.jpg?resize=477,350 477w" sizes="(max-width: 300px) 100vw, 300px" />							</a>
														<h3><a href="https://salisburypost.com/2021/04/06/high-school-football-broadway-making-plays/" rel="bookmark" title="High school football: Broadway making plays">High school football: Broadway making plays</a></h3>										
							<h4 class="date">Tuesday, April 6, 2021 12:00 am</h4>
							<p>By Mike London mike.london@salisburypost.com SALISBURY — A Ledford third-and-3 running play in the first quarter of Thursday&#8217;s Central Carolina Conference game was met with surprising&nbsp;... 
								<span class="meta">
									<a href="https://salisburypost.com/2021/04/06/high-school-football-broadway-making-plays/" class="noVisit readmore" rel="bookmark">Read&nbsp;more</a>
									| <a href="https://salisburypost.com/2021/04/06/high-school-football-broadway-making-plays/#disqus_thread" class="noVisit comments" rel="bookmark">Add your comment</a>
								</span>
							</p>

						</div><!-- END STORY -->
											</div>
					<div class="col last">
						<h3 class="section">Latest Sports</h3>
												<div class="story">
							<h3><a href="https://salisburypost.com/2021/04/09/high-school-girls-golf-waddell-medalist-but-east-trails-south-iredell/" rel="bookmark" title="High school girls golf: Waddell medalist, but East trails South Iredell">High school girls golf: Waddell medalist, but East trails South Iredell</a></h3>										

						</div><!-- END STORY -->
												<div class="story">
							<h3><a href="https://salisburypost.com/2021/04/09/high-school-football-davie-wins-in-ot/" rel="bookmark" title="High school football: Davie wins in OT">High school football: Davie wins in OT</a></h3>										

						</div><!-- END STORY -->
												<div class="story">
							<h3><a href="https://salisburypost.com/2021/04/09/nedeljkovic-excels-in-goal-as-hurricanes-blank-panthers-3-0/" rel="bookmark" title="Nedeljkovic excels in goal as Hurricanes blank Panthers 3-0">Nedeljkovic excels in goal as Hurricanes blank Panthers 3-0</a></h3>										

						</div><!-- END STORY -->
												<div class="more_stories">
							<h4><a href="/category/sports/">More Sports</a></h4>
						</div>
					</div>
				</div>
			</li>
		</ul>
		<!-- SPORTS DROP END -->
	</li>
	<li class="opinion"><a href="https://salisburypost.com/category/opinion/">Opinion</a>
		<!-- OPINION DROP -->
		<ul class="sub-nav">
			<li>
				<div class="contents">
					<div class="col first">
						<h3 class="section">In Opinion</h3>
            <ul class="left">
                <li><a href="https://salisburypost.com/category/opinion/columns-opinion/" title="Opinion - Columns | Salisbury, North Carolina - The Salisbury Post">Columns</a></li>
                <li><a href="https://salisburypost.com/category/opinion/common-sense/" title="Opinion - Common Sense | Salisbury, North Carolina - The Salisbury Post">Common Sense</a></li>
                <li><a href="https://salisburypost.com/category/opinion/letters/" title="Opinion - Letters | Salisbury, North Carolina - The Salisbury Post">Letters</a></li>
            </ul>
            <ul class="right">
                <li><a href="https://salisburypost.com/services/submit-letter/" target="_blank" title="Opinion - Submit a Letter | Salisbury, North Carolina - The Salisbury Post">Submit a Letter</a></li>
                <li><a href="https://salisburypost.com/category/opinion/editorials/" title="Opinion - Editorials | Salisbury, North Carolina - The Salisbury Post">Editorials</a></li>
                <li><a href="https://salisburypost.com/category/opinion/brincefield-cartoons/" title="Opinion - Brincefield Cartoons | Salisbury, North Carolina - The Salisbury Post">Brincefield Cartoons</a></li>
            </ul>

					</div>
					<div class="col">
						<h3 class="section">Top Opinion</h3>
												<div class="story">
														<a href="https://salisburypost.com/2021/04/08/laurels-infill-development-good-for-community/" rel="bookmark">
								<img width="300" height="170" src="https://salisburypost.com/wp-content/uploads/sites/9/2020/07/weblogo-ourview.jpg?w=300" class="attachment-medium size-medium wp-post-image" alt="" loading="lazy" srcset="https://salisburypost.com/wp-content/uploads/sites/9/2020/07/weblogo-ourview.jpg 622w, https://salisburypost.com/wp-content/uploads/sites/9/2020/07/weblogo-ourview.jpg?resize=300,170 300w, https://salisburypost.com/wp-content/uploads/sites/9/2020/07/weblogo-ourview.jpg?resize=618,350 618w" sizes="(max-width: 300px) 100vw, 300px" />							</a>
														<h3><a href="https://salisburypost.com/2021/04/08/laurels-infill-development-good-for-community/" rel="bookmark" title="Laurels: Infill development good for community">Laurels: Infill development good for community</a></h3>										
							<h4 class="date">Thursday, April 8, 2021 12:00 am</h4>
							<p>Laurel to two different proposals to add apartment units within already developed areas in Salisbury&#8217;s city limits. One complex will add dozens of units near&nbsp;... 
								<span class="meta">
									<a href="https://salisburypost.com/2021/04/08/laurels-infill-development-good-for-community/" class="noVisit readmore" rel="bookmark">Read&nbsp;more</a>
									| <a href="https://salisburypost.com/2021/04/08/laurels-infill-development-good-for-community/#disqus_thread" class="noVisit comments" rel="bookmark">Add your comment</a>
								</span>
							</p>

						</div><!-- END STORY -->
											</div>
					<div class="col last">
						<h3 class="section">Latest Opinion</h3>
												<div class="story">
							<h3><a href="https://salisburypost.com/2021/04/09/byron-york-justice-thomas-says-courts-will-rule-on-social-media-sooner-or-later/" rel="bookmark" title="Byron York: Justice Thomas says courts will rule on social media sooner or later">Byron York: Justice Thomas says courts will rule on social media sooner or later</a></h3>										

						</div><!-- END STORY -->
												<div class="story">
							<h3><a href="https://salisburypost.com/2021/04/09/quotes-of-the-week-216/" rel="bookmark" title="Quotes of the week">Quotes of the week</a></h3>										

						</div><!-- END STORY -->
												<div class="story">
							<h3><a href="https://salisburypost.com/2021/04/09/steven-v-roberts-these-political-orphans-deserve-help/" rel="bookmark" title="Steven V. Roberts: These ‘political orphans’  deserve help">Steven V. Roberts: These ‘political orphans’  deserve help</a></h3>										

						</div><!-- END STORY -->
												<div class="more_stories">
							<h4><a href="/category/opinion/">More Opinion</a></h4>
						</div>
					</div>
				</div>
			</li>
		</ul>
		<!-- OPINION DROP END -->
	</li>
	<li class="obituaries"><a href="http://www.legacy.com/obituaries/salisburypost/">Obits</a></li>
	<li class="classifieds"><a href="https://marketplace.salisburypost.com/adhunter/SalisburyPost/">Classifieds</a>
		<!-- CLASSIFIEDS DROP -->
		<ul class="sub-nav">
			<li>
				<div class="contents">
					<div class="col first">
            <ul class="left">
                <li><a href="https://marketplace.salisburypost.com/AdHunter/SalisburyPost/Home/Search?majorClass=2600">Public Notices</a></li>
                <li><a href="https://marketplace.salisburypost.com/Salisbury/">Place an Ad</a></li>
                <li><a href="https://marketplace.salisburypost.com/AdHunter/SalisburyPost/Home/Search?majorClass=1200">Merchandise</a></li>
                <li><a href="https://marketplace.salisburypost.com/AdHunter/SalisburyPost/Home/Search?majorClass=2000">Services</a></li>
                <li><a href="https://marketplace.salisburypost.com/AdHunter/SalisburyPost/Home/Search?majorClass=1900">Vehicles</a></li>
            </ul>
            <ul class="right">
                <li><a href="https://marketplace.salisburypost.com/AdHunter/SalisburyPost/Home/Search?majorClass=1000">Jobs</a></li>
                <li><a href="https://marketplace.salisburypost.com/AdHunter/SalisburyPost/Home/Search?majorClass=1800">Rentals</a></li>
                <li><a href="https://marketplace.salisburypost.com/AdHunter/SalisburyPost/Home/Search?majorClass=1700">Real Estate</a></li>
                <li><a href="https://marketplace.salisburypost.com/AdHunter/SalisburyPost/">All Classifieds</a></li>
            </ul>

					</div>
					<div class="col">
					</div>
					<div class="col last">
					</div>
				</div>
			</li>
		</ul>
		<!-- NEWS DROP END -->
	</li>
  <li class="calendar"><a href="https://salisburypost.com/calendar/">Calendar</a>
		<!-- CALENDAR DROP -->
		<ul class="sub-nav">
			<li>
				<div class="contents">
					<div class="col first">
            <ul class="left">
                <li><a href="https://salisburypost.com/dining/">Food &amp; Dining</a></li>
            </ul>
            <ul class="right">
            </ul>

					</div>
					<div class="col">
					</div>
					<div class="col last">
					</div>
				</div>
			</li>
		</ul>
		<!-- CALENDAR DROP END -->
  </li>
  <li class="Photos"><a href="http://salisburypost.mycapture.com/mycapture/index.asp">Photos</a></li>

	<li class="fun "><a href="https://salisburypost.com/fun/">Fun</a></li>


	<li>
								<div class="search">
									<form method="get" class="searchForm" action="https://salisburypost.com/site-search">
										<input type="submit" class="searchButton" value="Go" />
										<input type="text" name="q" class="searchQuery" value="Search Salisbury Post..." onfocus="if(this.value=='Search Salisbury Post...'){this.value='';}" onblur="if(this.value==''){this.value='Search Salisbury Post...';}" />
									</form>
								</div>
	</li>
</ul>
							</nav>
							<div class="clearfix"></div>
						</header>

						<div id="content" class="flownews">
							<div id="notifications">
																
																							</div>


<div class="one_by_one_group">
<!-- one_by_one_wall-->
<div id='div-gpt-ad-one_by_one_wall'>
<script type='text/javascript'>
jQuery(window).load(function() { // These functions get called when everything has loaded
	if (!loggedin) {
    googletag.cmd.push(function() { googletag.display('div-gpt-ad-one_by_one_wall'); });
  }
});
</script>
</div></div>

	


							<div class="main_column">
								<div class="story">
									
									
                    <div class="gallery_group">
      <div id="story_photo_group">
        
                                    <dl class='story_photo_item'><dt><img width="622" height="352" src="https://salisburypost.com/wp-content/uploads/sites/9/2020/07/weblogo-national.jpg?w=622" class="attachment-story-photo size-story-photo wp-post-image" alt="" loading="lazy" srcset="https://salisburypost.com/wp-content/uploads/sites/9/2020/07/weblogo-national.jpg 622w, https://salisburypost.com/wp-content/uploads/sites/9/2020/07/weblogo-national.jpg?resize=300,170 300w, https://salisburypost.com/wp-content/uploads/sites/9/2020/07/weblogo-national.jpg?resize=618,350 618w" sizes="(max-width: 622px) 100vw, 622px" /></dt><dd class='wp-caption-text'></dd></dl>

              </div>
    </div>

		
									<div id="leftRail" class="">
										<ul class="sidebar">
																						
		<li id="recent-posts-2" class="widget widget_recent_entries">
		<h2 class="widgettitle">Recent Posts</h2>

		<ul>
											<li>
					<a href="https://salisburypost.com/2021/04/09/man-woman-charged-for-selling-drugs-to-undercover-deputies/">Man, woman charged for selling drugs to undercover deputies</a>
									</li>
											<li>
					<a href="https://salisburypost.com/2021/04/09/blotter-rowan-county-man-charged-with-indecent-liberties-with-children/">Blotter: Rowan County man charged with indecent liberties with children</a>
									</li>
											<li>
					<a href="https://salisburypost.com/2021/04/09/high-school-girls-golf-waddell-medalist-but-east-trails-south-iredell/">High school girls golf: Waddell medalist, but East trails South Iredell</a>
									</li>
											<li>
					<a href="https://salisburypost.com/2021/04/09/high-school-football-davie-wins-in-ot/">High school football: Davie wins in OT</a>
									</li>
											<li>
					<a href="https://salisburypost.com/2021/04/09/spencer-town-board-gets-look-at-park-plaza-progress/">Spencer town board gets look at Park Plaza progress</a>
									</li>
					</ul>

		</li>
										</ul>

										<div class="ad">
												<!-- ROS_160x600_Sidebar -->
<div id='div-gpt-ad-skyscraper'>
  <script>
    googletag.cmd.push(function() { googletag.display('div-gpt-ad-skyscraper'); });
  </script>
</div>										</div>
									</div><!-- END LEFTRAIL -->

									<div id="article">

										<h2>Victim of former NFL player&#8217;s rampage wrote of faith, life&#8217;s fragility</h2>

										<div class="byline">
											
											<a href="https://salisburypost.com/author/news.service/" rel="bookmark">
                        <img alt='' src='https://secure.gravatar.com/avatar/012fbe6324f0f9ffc6c824c9ed4fc04c?s=120&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/012fbe6324f0f9ffc6c824c9ed4fc04c?s=240&#038;d=mm&#038;r=g 2x' class='avatar avatar-120 photo' height='120' width='120' loading='lazy'/>											</a>

											<p class="author">
                        <strong>By <a href="https://salisburypost.com/author/news-service/" rel="bookmark">News Service Report</a></strong>
																							</p>
											<p class="social">
												<a class="email" href="mailto:editor@salisburypost.com">Email the author</a>
																							</p>
											<p class="pubStamp">Published 12:00 am Friday, April 9, 2021</p>
																						<div class="clearfix"></div>
										</div><!-- END BYLINE -->

                    
                    <div class="one_by_one_group">
											<!-- extra_one_by_one -->
<div id='div-gpt-ad-extra_one_by_one'>
<script type='text/javascript'>
jQuery(window).load(function() { // These functions get called when everything has loaded
	if (!loggedin) {
    //console.log('========== BNI v10b not logged in ==========');
    googletag.cmd.push(function() { googletag.display('div-gpt-ad-extra_one_by_one'); });
  } else { 
    //console.log('========== BNI v10b logged in ==========');
  }
});
</script>
</div>											<!-- extra_one_by_one_two -->
<div id='div-gpt-ad-extra_one_by_one_two'>
<script type='text/javascript'>
jQuery(window).load(function() { // These functions get called when everything has loaded
	if (!loggedin) {
    //console.log('========== BNI v10b not logged in ==========');
    googletag.cmd.push(function() { googletag.display('div-gpt-ad-extra_one_by_one_two'); });
  } else { 
    //console.log('========== BNI v10b logged in ==========');
  }
});
  </script>
</div>											<!-- extra_oop -->
<div id='div-gpt-ad-extra_oop'>
<script type='text/javascript'>
jQuery(window).load(function() { // These functions get called when everything has loaded
	if (!loggedin) {
    //console.log('========== BNI v10b not logged in ==========');
    googletag.cmd.push(function() { googletag.display('div-gpt-ad-extra_oop'); });
  } else { 
    //console.log('========== BNI v10b logged in ==========');
  }
});
</script>
</div>                    </div>

										<div class="p402_premium">

										
										<div class="story_detail">
											
        <table id="trinity-audio-table" style="width:100%; display: table;">
            <tr>
                <td id="trinity-audio-tab" style="border: none;">
                    <div id="trinity-audio-player-label"></div>
                    <script>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</script><script type="text/javascript" src="https://trinitymedia.ai/player/trinity.php?viewkey=677143c5c1f3a1a2fcc0862c5951f602&postHash=8060dfda17cd9df3edc6c527283ad7f6&language=en-US&voiceGender=m&poweredby=1"></script>
                </td>
            </tr>
        </table><script>console.debug('TRINITY_WP', 'trinity_content_filter');</script><p>By MEG KINNARD</p>
<p>Associated Press</p>
<p>COLUMBIA, S.C. (AP) — Robert Lesslie, the South Carolina physician and author who authorities say was killed along with three family members and a repairman by former NFL player Phillip Adams, frequently wrote of the fragility of life and a deep-seated Christian faith that guided him personally and professionally.</p>
<div id='mydfpad' class='ad300x ad'><div id='div-gpt-ad-instory-top' style='width:300px; height:250px; clear:both;'>
                  <script type='text/javascript'>
                  googletag.cmd.push(function() { googletag.display('div-gpt-ad-instory-top'); });
                  </script>
                  </div>
                  </div>
                  <div id='cedato-unit'></div><p>&#8220;I know without a doubt that life is fragile,&#8221; the 70-year-old doctor wrote in one of his books, a collection of missives he termed &#8220;inspiring true stories&#8221; from his medical work. &#8220;I have come to understand that humility may be the greatest virtue. And I am convinced we need to take the time to say the things we deeply feel to the people we deeply care about.&#8221;</p>
<p>&#8220;Life is uncertain. Things happen. Lives are unexpectedly changed or ended. And it happens suddenly,&#8221; he wrote in post on his blog.</p>
<p>Lesslie&#8217;s lessons on faith were passed down to his children, as was evident in a statement from his family that law enforcement shared at a news conference on Thursday, a day after the attack. Even in their grief, the family said their &#8220;hearts are bent toward forgiveness and peace,&#8221; York County Sheriff Kevin Tolson told reporters. He said they were also praying for the family of Adams, a former NFL journeyman who authorities say shot and killed himself early Thursday after officers surrounded his parents&#8217; home.</p>
<div id='mydfpad3' class='ad'>
                  <div id='div-gpt-ad-instory-third'>
                  <script type='text/javascript'>
                  googletag.cmd.push(function() { googletag.display('div-gpt-ad-instory-third'); });
                  </script>
                  </div>
                  </div><p>According to police, Adams went to the home of Robert and Barbara Lesslie on Wednesday and shot and killed them, two of their grandchildren, 9-year-old Adah Lesslie and 5-year-old Noah Lesslie, and James Lewis, a 38-year-old air conditioning technician from Gaston who was doing work there. He also shot Lewis&#8217; colleague, 38-year-old Robert Shook, of Cherryville, North Carolina, who was flown to a Charlotte hospital, where he was in critical condition &#8220;fighting hard for his life,&#8221; said a cousin, Heather Smith Thompson.</p>
<p>Tolson said investigators hadn&#8217;t figured out why Adams carried out the attack: &#8220;There&#8217;s nothing right now that makes sense to any of us.&#8221;</p>
<p>A person briefed on the investigation who spoke to The Associated Press on the condition of anonymity because he wasn&#8217;t authorized to speak publicly said Robert Lesslie had treated Adams, who lived with his parents not far from the Lesslies&#8217; home.</p>
<p>Tolson would not confirm that Adams had been the doctor&#8217;s patient.</p>
<div id='mydfpad2' class='ad300x ad'>
                  <div id='div-gpt-ad-instory-bottom' style='width:300px; height:250px; clear:both;'>
                  <script type='text/javascript'>
                  googletag.cmd.push(function() { googletag.display('div-gpt-ad-instory-bottom'); });
                  </script>
                  </div>
                  </div><p>Barbara Lesslie had been heavily involved in fine arts, including theater in Rock Hill, said Gary Simrill, the Republican leader of the South Carolina House and a longtime Rock Hill resident. Having practiced medicine in Rock Hill for more than three decades, her husband had indeed treated many of its citizens. Simrill said that after years in emergency medicine, Robert Lesslie founded two urgent care centers that were the opposite of what many might expect from a quick-service medical practice.</p>
<p>&#8220;People developed a great relationship with him because he wasn&#8217;t just the doctor that saw you,&#8221; Simrill said. &#8220;He was the doctor that got to know you.&#8221;</p>
<p>Among his patients were Trent Faris, the spokesman for the York County Sheriff&#8217;s Office, and Adams&#8217; father, Alonzo Adams.</p>
<p>Tolson said evidence left at the shooting scene led investigators to Adams as a suspect. He said they went to Adams&#8217; parents&#8217; home, evacuated them and then persuade Adams to come out. Eventually, they found him dead of a single gunshot wound to the head in a bedroom, he said.</p>
<p>Adams, 32, played in 78 NFL games over five seasons for six teams. He joined the 49ers in 2010 as a seventh-round draft pick out of South Carolina State, and though he rarely started, he went on to play for New England, Seattle, Oakland and the New York Jets before finishing his career with the Atlanta Falcons in 2015.</p>
<p>As a rookie late in the 2010 season, Adams suffered a severe ankle injury that required surgery that included several screws being inserted into his leg. He never played for the 49ers again, getting released just before the 2011 season began. Later, with the Raiders, he had two concussions over three games in 2012.</p>
<p>Whether he suffered long-lasting concussion-related injuries wasn&#8217;t immediately clear. Adams would not have been eligible for testing as part of a broad settlement between the league and its former players over such injuries, because he hadn&#8217;t retired by 2014.</p>
<p>Adams&#8217; father told a Charlotte television station that he blamed football for problems his son had, and which might have led him to commit Wednesday&#8217;s violence.</p>
<p>&#8220;I can say he&#8217;s a good kid — he was a good kid, and I think the football messed him up,&#8221; Alonzo Adams told WCNC-TV. &#8220;He didn&#8217;t talk much and he didn&#8217;t bother nobody.&#8221;</p>
<p>Robert Lesslie reveled in writing about his faith and his work as a physician, penning more than half a dozen books that were collections of what he termed &#8220;inspiring true stories&#8221; from his work.</p>
<p>In a 2014 interview, he spoke of how he came to write one, &#8220;Angels in the ER,&#8221; saying he saw value in the stories he had collected through his decades in medicine, focusing on &#8220;people who had impacted me through their faith, and the way they had dealt with things that life had sent their way.&#8221;</p>
<p>&#8220;When I talk about angels, I do believe that God ministers to us in a lot of different ways,&#8221; Lesslie said.</p>
<p>&#8220;I don&#8217;t write about wings and halos and that kind of thing, but I do believe that God does speak to us through his spirit &#8211; and through other people.&#8221;</p>
<p>In a Thursday message to congregants, pastors from the Lesslies&#8217; church, First Associate Reformed Presbyterian Rock Hill, wrote that all four of the Lesslies &#8220;are in the presence of Jesus and worshipping Him face to face. One day we will see them again. Therefore, we can grieve as those who have hope.&#8221;</p>
<p>The church planned to keep its sanctuary open until 8 p.m. Thursday, for anyone wishing to pray. According to church officials, no funeral arrangements had been finalized.</p>
<p>As he wrote on his blog recently, Lesslie felt comfortable in his faith, imagining Heaven as a place filled with joy, and where he would be reunited with family and his cherished dog, Dox.</p>
<p>&#8220;We have no idea what Heaven will look like, only that it will be perfect,&#8221; Lesslie wrote. &#8220;And because of that I know that one day, when I&#8217;ve experienced the presence and joy of that surrounding host of saints, I will find myself walking with Barbara in a field of lush, green grass. &#8230; The words of Jesus will echo through that glade — &#8216;Behold, I make all things new.'&#8221;</p>
<p>___</p>
<p>Contributors include Michelle Liu in Rock Hill, S.C.; AP Pro Football Writers Barry Wilner in New York and Rob Maaddi in Philadelphia; sports writer Josh Dubow in Alameda, Calif.; legal affairs writer Maryclaire Dale in Philadelphia; and Nell Redmond in Rock Hill. Meg Kinnard can be reached at http://twitter.com/MegKinnardAP.</p>

                                            



										</div><!-- END STORY_DETAIL -->
										</div><!-- END p402_premium (GOOGLE SURVEY) -->
										<script type="text/javascript">
											 var load_402_show_function = function () { try { _402_Show(); } catch(e) { } }
										</script>

                      <div class="prev_next_article">
  <!-- v 1.8 -->

                              <div class="next_article">
        <div class="padding">
          <div class="label">You Might Like</div>
                    <div class="thumb">
            <a href="https://salisburypost.com/2021/04/09/wrongly-imprisoned-man-gets-750000/">
              <img src="https://salisburypost.com/wp-content/uploads/sites/9/2020/07/weblogo-state.jpg?w=90&h=90&crop=1" alt="" width="50" height="50">
            </a>
          </div>
                    <h4> <a href="https://salisburypost.com/2021/04/09/wrongly-imprisoned-man-gets-750000/">Wrongly imprisoned man gets $750,000</a></h4>
          <p>Associated Press DURHAM — A man who served nearly 44 years in prison for a crime he says he didn’t... <a href="https://salisburypost.com/2021/04/09/wrongly-imprisoned-man-gets-750000/">read more</a></p>
        </div>
      </div>
        <div class="clearfix"></div>
  </div>


												
											<div class="print_this">
													<a href="#">Print Article</a>
											</div><!-- END print_this -->


											<div class="articleOptions">
												<div class="admin">
</div>
<div class="clearfix"></div>


											</div>


                      

<div class="rev_ad">
  <div id="rc-widget-61eef3" data-rc-widget data-widget-host="habitat" data-endpoint="//trends.revcontent.com" data-widget-id="112875"></div>
        <script type="text/javascript" src="https://assets.revcontent.com/master/delivery.js" defer="defer"></script>
  </div>
  

	
<div class="one_by_one_group">
<!-- one_by_one_duration-->
<div id='div-gpt-ad-one_by_one_duration'>
  <script>
    googletag.cmd.push(function() { googletag.display('div-gpt-ad-one_by_one_duration'); });
  </script>
</div><div id="rev_video"></div>
</div>



											<div id="disqus_thread"></div>
<h3>Comments</h3>

  <div class="fb-comments" data-href="https://www.salisburypost.com/2021/04/09/victim-of-former-nfl-players-rampage-wrote-of-faith-lifes-fragility/" data-width="100%" data-numposts="5" data-colorscheme="light"></div>
 


<div id="fb-root"></div>
<script>(function(d, s, id) {
  var js, fjs = d.getElementsByTagName(s)[0];
  if (d.getElementById(id)) return;
  js = d.createElement(s); js.id = id;
	js.async = true;
  js.src = 'https://connect.facebook.net/en_US/sdk.js#xfbml=1&version=v2.12&appId=168913723140235&autoLogAppEvents=1';
  fjs.parentNode.insertBefore(js, fjs);
}(document, 'script', 'facebook-jssdk'));</script>

									</div>
									<div class="clearfix"></div>

								</div>
							</div>
							<div class="col last">
								
<ul class="sidebar">

	<li>
		<div class="ad first">
			<div id='div-gpt-ad-bigblock-1'>
  <script>
    googletag.cmd.push(function() { googletag.display('div-gpt-ad-bigblock-1'); });
  </script>
</div>		</div>
		<div class="ad ">
			<div id='div-gpt-ad-bigblock-18'>
  <script>
    googletag.cmd.push(function() { googletag.display('div-gpt-ad-bigblock-18'); });
  </script>
</div>		</div>


	</li>
	<style>.rpwe-block ul{
list-style: none !important;
margin-left: 0 !important;
padding-left: 0 !important;
}

.rpwe-block li{
border-bottom: 1px solid #eee;
margin-bottom: 10px;
padding-bottom: 10px;
list-style-type: none;
}

.rpwe-block a{
display: inline !important;
text-decoration: none;
}

.rpwe-block h3{
background: none !important;
clear: none;
margin-bottom: 0 !important;
margin-top: 0 !important;
font-weight: 400;
font-size: 12px !important;
line-height: 1.5em;
}

.rpwe-thumb{
border: 1px solid #eee !important;
box-shadow: none !important;
margin: 2px 10px 2px 0;
padding: 3px !important;
}

.rpwe-summary{
font-size: 12px;
}

.rpwe-time{
color: #bbb;
font-size: 11px;
}

.rpwe-comment{
color: #bbb;
font-size: 11px;
padding-left: 5px;
}

.rpwe-alignleft{
display: inline;
float: left;
}

.rpwe-alignright{
display: inline;
float: right;
}

.rpwe-aligncenter{
display: block;
margin-left: auto;
margin-right: auto;
}

.rpwe-clearfix:before,
.rpwe-clearfix:after{
content: "";
display: table !important;
}

.rpwe-clearfix:after{
clear: both;
}

.rpwe-clearfix{
zoom: 1;
}
</style><li id="rpwe_widget-2" class="widget rpwe_widget recent-posts-extended"><h2 class="widgettitle">LATEST LOCAL NEWS</h2>
<div  class="rpwe-block "><ul class="rpwe-ul"><li class="rpwe-li rpwe-clearfix"><h3 class="rpwe-title"><a href="https://salisburypost.com/2021/04/09/man-woman-charged-for-selling-drugs-to-undercover-deputies/" title="Permalink to Man, woman charged for selling drugs to undercover deputies" rel="bookmark">Man, woman charged for selling drugs to undercover deputies</a></h3></li><li class="rpwe-li rpwe-clearfix"><h3 class="rpwe-title"><a href="https://salisburypost.com/2021/04/09/blotter-rowan-county-man-charged-with-indecent-liberties-with-children/" title="Permalink to Blotter: Rowan County man charged with indecent liberties with children" rel="bookmark">Blotter: Rowan County man charged with indecent liberties with children</a></h3></li><li class="rpwe-li rpwe-clearfix"><h3 class="rpwe-title"><a href="https://salisburypost.com/2021/04/09/spencer-town-board-gets-look-at-park-plaza-progress/" title="Permalink to Spencer town board gets look at Park Plaza progress" rel="bookmark">Spencer town board gets look at Park Plaza progress</a></h3></li><li class="rpwe-li rpwe-clearfix"><h3 class="rpwe-title"><a href="https://salisburypost.com/2021/04/09/applicant-market-unemployment-rate-improving-as-businesses-hire-more-workers/" title="Permalink to &#8216;Applicant market&#8217;: Unemployment rate improving as businesses hire more workers" rel="bookmark">&#8216;Applicant market&#8217;: Unemployment rate improving as businesses hire more workers</a></h3></li><li class="rpwe-li rpwe-clearfix"><h3 class="rpwe-title"><a href="https://salisburypost.com/2021/04/09/national-local-business-leaders-praise-salisburys-initiative-to-support-black-owned-operations/" title="Permalink to National, local business leaders praise Salisbury&#8217;s initiative to support Black-owned operations" rel="bookmark">National, local business leaders praise Salisbury&#8217;s initiative to support Black-owned operations</a></h3></li></ul></div><!-- Generated by http://wordpress.org/plugins/recent-posts-widget-extended/ --></li>
<li id="custom_html-3" class="widget_text widget widget_custom_html"><div class="textwidget custom-html-widget">		 <div data-cswidget="8627" > </div>
    <script type="text/javascript" async defer src="//cdn.cityspark.com/wid/get.js" > </script>
<br>
<iframe src="https://salisburypost.friends2follow.com/f2f/widget/html/postfeed2/101/0/12/140/1/1/1/9/9/1" width="300px" height="550px" frameborder="0" scrolling="no"></iframe>
<br>		
<div data-cswidget="L1007"> </div>
<script type="text/javascript" async defer src="//cdn.cityspark.com/wid/get.js" > </script>

<div id="ap_widget_container_ca890116f6b1d98085d4fd61ca134e18"></div>
<script src="https://digitalservices.ap.org/assets/js/resizer.client.min.js" type="text/javascript"></script><iframe id="iframe_13947f0def41fee1d836d75ce3839363" style="overflow: hidden; min-width: 100%; border: none;" src="https://pro32.ap.org/iframe/widgets/content/13947f0def41fee1d836d75ce3839363" width="100%" height="100%" frameborder="1" allowfullscreen="allowfullscreen" onload="iFrameResize({}, '#iframe_13947f0def41fee1d836d75ce3839363');"></iframe>
<br />
		<a href="http://salisburypost.nc.newsmemory.com/marketplace.php">
			<img src="//www.salisburypost.com/wp-content/uploads/2016/10/shopping-marketplace-bar-for-web300.jpg" alt="">
		</a>
		<br />
</div></li>
	<li id="polls-widget-2" class="widget widget_polls-widget"><h2 class="widgettitle">Polls</h2>
<div id="polls-102" class="wp-polls">
	<form id="polls_form_102" class="wp-polls-form" action="/index.php" method="post">
		<p style="display: none;"><input type="hidden" id="poll_102_nonce" name="wp-polls-nonce" value="9edf2b6208" /></p>
		<p style="display: none;"><input type="hidden" name="poll_id" value="102" /></p>
		<p style="text-align: center;"><strong>Should people be required to show 'vaccine passports' for travel and other situations where proof of COVID-19 vaccinations are required?</strong></p><div id="polls-102-ans" class="wp-polls-ans"><ul class="wp-polls-ul">
		<li><input type="radio" id="poll-answer-453" name="poll_102" value="453" /> <label for="poll-answer-453">Yes</label></li>
		<li><input type="radio" id="poll-answer-454" name="poll_102" value="454" /> <label for="poll-answer-454">No</label></li>
		<li><input type="radio" id="poll-answer-455" name="poll_102" value="455" /> <label for="poll-answer-455">Not sure</label></li>
		</ul><p style="text-align: center;"><input type="button" name="vote" value="   Vote   " class="Buttons" onclick="poll_vote(102);" /></p><p style="text-align: center;"><a href="#ViewPollResults" onclick="poll_result(102); return false;" title="View Results Of This Poll">View Results</a></p></div>
	</form>
</div>
<div id="polls-102-loading" class="wp-polls-loading"><img src="https://www.salisburypost.com/wp-content/plugins/wp-polls/images/loading.gif" width="16" height="16" alt="Loading ..." title="Loading ..." class="wp-polls-image" />&nbsp;Loading ...</div>
<ul><li><a href="">Polls Archive</a></li></ul></li>
	<li>

		<div class="ad">
			<div id='div-gpt-ad-bigblock-2'>
  <script>
    googletag.cmd.push(function() { googletag.display('div-gpt-ad-bigblock-2'); });
  </script>
</div>		</div>
	</li>
	<style>.rpwe-block ul{
list-style: none !important;
margin-left: 0 !important;
padding-left: 0 !important;
}

.rpwe-block li{
border-bottom: 1px solid #eee;
margin-bottom: 10px;
padding-bottom: 10px;
list-style-type: none;
}

.rpwe-block a{
display: inline !important;
text-decoration: none;
}

.rpwe-block h3{
background: none !important;
clear: none;
margin-bottom: 0 !important;
margin-top: 0 !important;
font-weight: 400;
font-size: 12px !important;
line-height: 1.5em;
}

.rpwe-thumb{
border: 1px solid #eee !important;
box-shadow: none !important;
margin: 2px 10px 2px 0;
padding: 3px !important;
}

.rpwe-summary{
font-size: 12px;
}

.rpwe-time{
color: #bbb;
font-size: 11px;
}

.rpwe-comment{
color: #bbb;
font-size: 11px;
padding-left: 5px;
}

.rpwe-alignleft{
display: inline;
float: left;
}

.rpwe-alignright{
display: inline;
float: right;
}

.rpwe-aligncenter{
display: block;
margin-left: auto;
margin-right: auto;
}

.rpwe-clearfix:before,
.rpwe-clearfix:after{
content: "";
display: table !important;
}

.rpwe-clearfix:after{
clear: both;
}

.rpwe-clearfix{
zoom: 1;
}
</style><li id="rpwe_widget-3" class="widget rpwe_widget recent-posts-extended"><h2 class="widgettitle">LATEST OPINION</h2>
<div  class="rpwe-block "><ul class="rpwe-ul"><li class="rpwe-li rpwe-clearfix"><h3 class="rpwe-title"><a href="https://salisburypost.com/2021/04/09/byron-york-justice-thomas-says-courts-will-rule-on-social-media-sooner-or-later/" title="Permalink to Byron York: Justice Thomas says courts will rule on social media sooner or later" rel="bookmark">Byron York: Justice Thomas says courts will rule on social media sooner or later</a></h3></li><li class="rpwe-li rpwe-clearfix"><h3 class="rpwe-title"><a href="https://salisburypost.com/2021/04/09/quotes-of-the-week-216/" title="Permalink to Quotes of the week" rel="bookmark">Quotes of the week</a></h3></li><li class="rpwe-li rpwe-clearfix"><h3 class="rpwe-title"><a href="https://salisburypost.com/2021/04/09/steven-v-roberts-these-political-orphans-deserve-help/" title="Permalink to Steven V. Roberts: These ‘political orphans’  deserve help" rel="bookmark">Steven V. Roberts: These ‘political orphans’  deserve help</a></h3></li><li class="rpwe-li rpwe-clearfix"><h3 class="rpwe-title"><a href="https://salisburypost.com/2021/04/08/my-turn-ed-norvell-do-we-want-to-continue-to-litigate-confederate-monument/" title="Permalink to My Turn, Ed Norvell: Do we want to continue to litigate Confederate monument?" rel="bookmark">My Turn, Ed Norvell: Do we want to continue to litigate Confederate monument?</a></h3></li><li class="rpwe-li rpwe-clearfix"><h3 class="rpwe-title"><a href="https://salisburypost.com/2021/04/08/letter-viewed-through-alternative-eyes/" title="Permalink to Letter: Viewed through &#8216;alternative eyes&#8217;" rel="bookmark">Letter: Viewed through &#8216;alternative eyes&#8217;</a></h3></li></ul></div><!-- Generated by http://wordpress.org/plugins/recent-posts-widget-extended/ --></li>
<li id="custom_html-6" class="widget_text widget widget_custom_html"><div class="textwidget custom-html-widget"><script src="https://digitalservices.ap.org/assets/js/resizer.client.min.js" type="text/javascript"></script><iframe id="iframe_c24754ee9ca7c39e1d5b87941f432e70" style="overflow: hidden; min-width: 100%; border: none;" src="https://racing.ap.org/iframe/widgets/content/c24754ee9ca7c39e1d5b87941f432e70" width="100%" height="100%" frameborder="1" allowfullscreen="allowfullscreen" onload="iFrameResize({}, '#iframe_c24754ee9ca7c39e1d5b87941f432e70');"></iframe>		</div></li>
<style>.rpwe-block ul{
list-style: none !important;
margin-left: 0 !important;
padding-left: 0 !important;
}

.rpwe-block li{
border-bottom: 1px solid #eee;
margin-bottom: 10px;
padding-bottom: 10px;
list-style-type: none;
}

.rpwe-block a{
display: inline !important;
text-decoration: none;
}

.rpwe-block h3{
background: none !important;
clear: none;
margin-bottom: 0 !important;
margin-top: 0 !important;
font-weight: 400;
font-size: 12px !important;
line-height: 1.5em;
}

.rpwe-thumb{
border: 1px solid #eee !important;
box-shadow: none !important;
margin: 2px 10px 2px 0;
padding: 3px !important;
}

.rpwe-summary{
font-size: 12px;
}

.rpwe-time{
color: #bbb;
font-size: 11px;
}

.rpwe-comment{
color: #bbb;
font-size: 11px;
padding-left: 5px;
}

.rpwe-alignleft{
display: inline;
float: left;
}

.rpwe-alignright{
display: inline;
float: right;
}

.rpwe-aligncenter{
display: block;
margin-left: auto;
margin-right: auto;
}

.rpwe-clearfix:before,
.rpwe-clearfix:after{
content: "";
display: table !important;
}

.rpwe-clearfix:after{
clear: both;
}

.rpwe-clearfix{
zoom: 1;
}
</style><li id="rpwe_widget-4" class="widget rpwe_widget recent-posts-extended"><h2 class="widgettitle">LATEST BUSINESS</h2>
<div  class="rpwe-block "><ul class="rpwe-ul"><li class="rpwe-li rpwe-clearfix"><h3 class="rpwe-title"><a href="https://salisburypost.com/2021/04/09/applicant-market-unemployment-rate-improving-as-businesses-hire-more-workers/" title="Permalink to &#8216;Applicant market&#8217;: Unemployment rate improving as businesses hire more workers" rel="bookmark">&#8216;Applicant market&#8217;: Unemployment rate improving as businesses hire more workers</a></h3></li><li class="rpwe-li rpwe-clearfix"><h3 class="rpwe-title"><a href="https://salisburypost.com/2021/04/08/two-major-economic-development-projects-planned-for-southern-rowan-county/" title="Permalink to Two major economic development projects planned for southern Rowan County" rel="bookmark">Two major economic development projects planned for southern Rowan County</a></h3></li><li class="rpwe-li rpwe-clearfix"><h3 class="rpwe-title"><a href="https://salisburypost.com/2021/04/08/city-to-host-qa-session-to-discuss-new-initiative-supporting-increasing-black-owned-businesses/" title="Permalink to City to host Q&#038;A session to discuss initiative to increase Black-owned businesses" rel="bookmark">City to host Q&#038;A session to discuss initiative to increase Black-owned businesses</a></h3></li><li class="rpwe-li rpwe-clearfix"><h3 class="rpwe-title"><a href="https://salisburypost.com/2021/04/08/chamber-will-celebrate-95th-annual-meeting-virtually-with-several-fun-twists/" title="Permalink to Chamber will celebrate 95th annual meeting virtually, with several &#8216;fun twists&#8217;" rel="bookmark">Chamber will celebrate 95th annual meeting virtually, with several &#8216;fun twists&#8217;</a></h3></li><li class="rpwe-li rpwe-clearfix"><h3 class="rpwe-title"><a href="https://salisburypost.com/2021/04/06/with-a-brand-new-look-skinny-wheels-bike-shop-welcomes-customers-back-in-store/" title="Permalink to With a brand new look, Skinny Wheels Bike Shop welcomes customers back in store" rel="bookmark">With a brand new look, Skinny Wheels Bike Shop welcomes customers back in store</a></h3></li></ul></div><!-- Generated by http://wordpress.org/plugins/recent-posts-widget-extended/ --></li>
	<li>
		<div class="story_list widget">
			<ul>
							</ul>
		</div>
	</li>
		<li>
		<div class="ad">
			<div id='div-gpt-ad-bigblock-3'>
  <script>
    googletag.cmd.push(function() { googletag.display('div-gpt-ad-bigblock-3'); });
  </script>
</div>		</div>
	</li>

	<style>.rpwe-block ul{
list-style: none !important;
margin-left: 0 !important;
padding-left: 0 !important;
}

.rpwe-block li{
border-bottom: 1px solid #eee;
margin-bottom: 10px;
padding-bottom: 10px;
list-style-type: none;
}

.rpwe-block a{
display: inline !important;
text-decoration: none;
}

.rpwe-block h3{
background: none !important;
clear: none;
margin-bottom: 0 !important;
margin-top: 0 !important;
font-weight: 400;
font-size: 12px !important;
line-height: 1.5em;
}

.rpwe-thumb{
border: 1px solid #eee !important;
box-shadow: none !important;
margin: 2px 10px 2px 0;
padding: 3px !important;
}

.rpwe-summary{
font-size: 12px;
}

.rpwe-time{
color: #bbb;
font-size: 11px;
}

.rpwe-comment{
color: #bbb;
font-size: 11px;
padding-left: 5px;
}

.rpwe-alignleft{
display: inline;
float: left;
}

.rpwe-alignright{
display: inline;
float: right;
}

.rpwe-aligncenter{
display: block;
margin-left: auto;
margin-right: auto;
}

.rpwe-clearfix:before,
.rpwe-clearfix:after{
content: "";
display: table !important;
}

.rpwe-clearfix:after{
clear: both;
}

.rpwe-clearfix{
zoom: 1;
}
</style><li id="rpwe_widget-5" class="widget rpwe_widget recent-posts-extended"><h2 class="widgettitle">LATEST LIFESTYLE</h2>
<div  class="rpwe-block "><ul class="rpwe-ul"><li class="rpwe-li rpwe-clearfix"><h3 class="rpwe-title"><a href="https://salisburypost.com/2021/04/04/ann-farabee-column-a-little-farther/" title="Permalink to Ann Farabee column: A little farther" rel="bookmark">Ann Farabee column: A little farther</a></h3></li><li class="rpwe-li rpwe-clearfix"><h3 class="rpwe-title"><a href="https://salisburypost.com/2021/04/04/ester-marsh-the-power-of-focusing-on-positive-things/" title="Permalink to Ester Marsh: The power of focusing on positive things" rel="bookmark">Ester Marsh: The power of focusing on positive things</a></h3></li><li class="rpwe-li rpwe-clearfix"><h3 class="rpwe-title"><a href="https://salisburypost.com/2021/04/04/counting-our-blessings-and-the-easter-eggs/" title="Permalink to Counting our blessings — and the Easter Eggs" rel="bookmark">Counting our blessings — and the Easter Eggs</a></h3></li><li class="rpwe-li rpwe-clearfix"><h3 class="rpwe-title"><a href="https://salisburypost.com/2021/04/04/gotta-run-brayden-self-a-good-example-for-young-runners/" title="Permalink to Gotta’ Run: Brayden Self sets good example for young runners" rel="bookmark">Gotta’ Run: Brayden Self sets good example for young runners</a></h3></li><li class="rpwe-li rpwe-clearfix"><h3 class="rpwe-title"><a href="https://salisburypost.com/2021/04/04/darrell-blackwelder-column-leyland-cypress-is-very-susceptible-to-insects-and-disease/" title="Permalink to Darrell Blackwelder column: Leyland cypress is very susceptible to insects and disease" rel="bookmark">Darrell Blackwelder column: Leyland cypress is very susceptible to insects and disease</a></h3></li></ul></div><!-- Generated by http://wordpress.org/plugins/recent-posts-widget-extended/ --></li>
<li id="custom_html-4" class="widget_text widget widget_custom_html"><div class="textwidget custom-html-widget">		<a href="http://salisburypost.nc.newsmemory.com/ssindex.php">
			<img src="//www.salisburypost.com/wp-content/uploads/2016/10/special-section-bar-for-web300.jpg" alt="">
		</a>

		<br />
		<br />

		<script language="JavaScript" src="https://salisburypost.mycapture.com/datafeeds/28095.js"></script></div></li>
<li id="custom_html-7" class="widget_text widget widget_custom_html"><div class="textwidget custom-html-widget"><script src="https://digitalservices.ap.org/assets/js/resizer.client.min.js" type="text/javascript"></script><iframe id="iframe_bde00e4c8bdeeb4f1e1ee7efbf372056" style="overflow: hidden; min-width: 100%; border: none;" src="https://racing.ap.org/iframe/widgets/content/bde00e4c8bdeeb4f1e1ee7efbf372056" width="100%" height="100%" frameborder="1" allowfullscreen="allowfullscreen" onload="iFrameResize({}, '#iframe_bde00e4c8bdeeb4f1e1ee7efbf372056');"></iframe></div></li>

	<li>
		<div class="ad">
			<div id='div-gpt-ad-halfpage-1'>
  <script>
    googletag.cmd.push(function() { googletag.display('div-gpt-ad-halfpage-1'); });
  </script>
</div>		</div>
	</li>
  
</ul>							</div>

              							<div id="flow_news">
								<div id="flow_news_slider">
									<div class="wrap ca-wrapper">
																				<div class="story ca-item">
											<h4 class="category">Crime</h4>
											<h3><a href="https://salisburypost.com/2021/04/09/man-woman-charged-for-selling-drugs-to-undercover-deputies/" rel="bookmark" title="Man, woman charged for selling drugs to undercover deputies">Man, woman charged for selling drugs to undercover deputies</a></h3>
										</div><!-- END STORY -->
																				<div class="story ca-item">
											<h4 class="category">Crime</h4>
											<h3><a href="https://salisburypost.com/2021/04/09/blotter-rowan-county-man-charged-with-indecent-liberties-with-children/" rel="bookmark" title="Blotter: Rowan County man charged with indecent liberties with children">Blotter: Rowan County man charged with indecent liberties with children</a></h3>
										</div><!-- END STORY -->
																				<div class="story ca-item">
											<h4 class="category">Local</h4>
											<h3><a href="https://salisburypost.com/2021/04/09/spencer-town-board-gets-look-at-park-plaza-progress/" rel="bookmark" title="Spencer town board gets look at Park Plaza progress">Spencer town board gets look at Park Plaza progress</a></h3>
										</div><!-- END STORY -->
																				<div class="story ca-item">
											<h4 class="category">Business</h4>
											<h3><a href="https://salisburypost.com/2021/04/09/applicant-market-unemployment-rate-improving-as-businesses-hire-more-workers/" rel="bookmark" title="&#8216;Applicant market&#8217;: Unemployment rate improving as businesses hire more workers">&#8216;Applicant market&#8217;: Unemployment rate improving as businesses hire more workers</a></h3>
										</div><!-- END STORY -->
																				<div class="story ca-item">
											<h4 class="category">Local</h4>
											<h3><a href="https://salisburypost.com/2021/04/09/national-local-business-leaders-praise-salisburys-initiative-to-support-black-owned-operations/" rel="bookmark" title="National, local business leaders praise Salisbury&#8217;s initiative to support Black-owned operations">National, local business leaders praise Salisbury&#8217;s initiative to support Black-owned operations</a></h3>
										</div><!-- END STORY -->
																				<div class="story ca-item">
											<h4 class="category">Nation/World</h4>
											<h3><a href="https://salisburypost.com/2021/04/09/tillis-has-prostate-cancer-surgery/" rel="bookmark" title="Tillis has prostate cancer surgery">Tillis has prostate cancer surgery</a></h3>
										</div><!-- END STORY -->
																				<div class="story ca-item">
											<h4 class="category">Coronavirus</h4>
											<h3><a href="https://salisburypost.com/2021/04/09/adverse-reactions-surface-from-johnson-johnson-vaccine/" rel="bookmark" title="Adverse reactions surface from Johnson &#038; Johnson vaccine">Adverse reactions surface from Johnson &#038; Johnson vaccine</a></h3>
										</div><!-- END STORY -->
																				<div class="story ca-item">
											<h4 class="category">Nation/World</h4>
											<h3><a href="https://salisburypost.com/2021/04/09/expert-lack-of-oxygen-killed-george-floyd-not-drugs/" rel="bookmark" title="Expert: Lack of oxygen killed George Floyd, not drugs">Expert: Lack of oxygen killed George Floyd, not drugs</a></h3>
										</div><!-- END STORY -->
																				<div class="story ca-item">
											<h4 class="category">Local</h4>
											<h3><a href="https://salisburypost.com/2021/04/09/quotes-of-the-week-216/" rel="bookmark" title="Quotes of the week">Quotes of the week</a></h3>
										</div><!-- END STORY -->
																				<div class="story ca-item">
											<h4 class="category">Nation/World</h4>
											<h3><a href="https://salisburypost.com/2021/04/09/biden-seeks-crackdown-on-homemade-firearms/" rel="bookmark" title="Biden seeks crackdown on homemade firearms">Biden seeks crackdown on homemade firearms</a></h3>
										</div><!-- END STORY -->
																				<div class="story ca-item">
											<h4 class="category">Nation/World</h4>
											<h3><a href="https://salisburypost.com/2021/04/09/victim-of-former-nfl-players-rampage-wrote-of-faith-lifes-fragility/" rel="bookmark" title="Victim of former NFL player&#8217;s rampage wrote of faith, life&#8217;s fragility">Victim of former NFL player&#8217;s rampage wrote of faith, life&#8217;s fragility</a></h3>
										</div><!-- END STORY -->
																				<div class="story ca-item">
											<h4 class="category">News</h4>
											<h3><a href="https://salisburypost.com/2021/04/09/wrongly-imprisoned-man-gets-750000/" rel="bookmark" title="Wrongly imprisoned man gets $750,000">Wrongly imprisoned man gets $750,000</a></h3>
										</div><!-- END STORY -->
																				<div class="story ca-item">
											<h4 class="category">High School</h4>
											<h3><a href="https://salisburypost.com/2021/04/09/west-falls-to-statesville-finishes-second-in-npc/" rel="bookmark" title="West falls to Statesville, finishes second in NPC">West falls to Statesville, finishes second in NPC</a></h3>
										</div><!-- END STORY -->
																				<div class="story ca-item">
											<h4 class="category">Education</h4>
											<h3><a href="https://salisburypost.com/2021/04/08/middle-high-school-students-head-back-to-classes-full-time/" rel="bookmark" title="Middle, high school students head back to classes full time">Middle, high school students head back to classes full time</a></h3>
										</div><!-- END STORY -->
																				<div class="story ca-item">
											<h4 class="category">Coronavirus</h4>
											<h3><a href="https://salisburypost.com/2021/04/08/1000-new-covid-19-vaccinations-reported-thursday/" rel="bookmark" title="1,000 new COVID-19 vaccinations reported Thursday">1,000 new COVID-19 vaccinations reported Thursday</a></h3>
										</div><!-- END STORY -->
																				<div class="story ca-item">
											<h4 class="category">Landis</h4>
											<h3><a href="https://salisburypost.com/2021/04/08/landis-man-airlifted-after-being-crushed-in-front-porch-collapse/" rel="bookmark" title="Landis man airlifted after being crushed in porch collapse">Landis man airlifted after being crushed in porch collapse</a></h3>
										</div><!-- END STORY -->
																				<div class="story ca-item">
											<h4 class="category">Crime</h4>
											<h3><a href="https://salisburypost.com/2021/04/08/blotter-salisbury-man-charged-with-embezzlement/" rel="bookmark" title="Blotter: Salisbury man charged with embezzlement">Blotter: Salisbury man charged with embezzlement</a></h3>
										</div><!-- END STORY -->
																				<div class="story ca-item">
											<h4 class="category">Crime</h4>
											<h3><a href="https://salisburypost.com/2021/04/08/one-faces-conspiracy-larceny-charges-two-still-sought-in-rowan-sheriffs-office-investigation/" rel="bookmark" title="Man faces conspiracy, larceny charges; two others sought in Rowan Sheriff&#8217;s Office investigation">Man faces conspiracy, larceny charges; two others sought in Rowan Sheriff&#8217;s Office investigation</a></h3>
										</div><!-- END STORY -->
																				<div class="story ca-item">
											<h4 class="category">Local</h4>
											<h3><a href="https://salisburypost.com/2021/04/08/rowan-museums-utzman-chambers-house-becomes-site-of-bee-hive-carpenter-bee-infestation/" rel="bookmark" title="Rowan Museum&#8217;s Utzman-Chambers House becomes site of bee hive, carpenter bee infestation">Rowan Museum&#8217;s Utzman-Chambers House becomes site of bee hive, carpenter bee infestation</a></h3>
										</div><!-- END STORY -->
																				<div class="story ca-item">
											<h4 class="category">Business</h4>
											<h3><a href="https://salisburypost.com/2021/04/08/two-major-economic-development-projects-planned-for-southern-rowan-county/" rel="bookmark" title="Two major economic development projects planned for southern Rowan County">Two major economic development projects planned for southern Rowan County</a></h3>
										</div><!-- END STORY -->
																				<div class="story ca-item">
											<h4 class="category">Education</h4>
											<h3><a href="https://salisburypost.com/2021/04/08/local-nursing-students-maneuver-through-hurdles-during-a-pandemic/" rel="bookmark" title="Local nursing students maneuver through hurdles during pandemic">Local nursing students maneuver through hurdles during pandemic</a></h3>
										</div><!-- END STORY -->
																				<div class="story ca-item">
											<h4 class="category">Coronavirus</h4>
											<h3><a href="https://salisburypost.com/2021/04/08/county-sees-two-more-covid-19-deaths-bringing-total-to-299/" rel="bookmark" title="County sees two more COVID-19 deaths, bringing total to 299">County sees two more COVID-19 deaths, bringing total to 299</a></h3>
										</div><!-- END STORY -->
																				<div class="story ca-item">
											<h4 class="category">Education</h4>
											<h3><a href="https://salisburypost.com/2021/04/08/shoutouts-121/" rel="bookmark" title="Shoutouts">Shoutouts</a></h3>
										</div><!-- END STORY -->
																				<div class="story ca-item">
											<h4 class="category">Education</h4>
											<h3><a href="https://salisburypost.com/2021/04/08/education-briefs-simms-maddox-to-speak-at-livingstones-virtual-women-in-history-program/" rel="bookmark" title="Education briefs: Simms-Maddox to speak at Livingstone’s virtual Women in History program">Education briefs: Simms-Maddox to speak at Livingstone’s virtual Women in History program</a></h3>
										</div><!-- END STORY -->
																			</div>
								</div>
							</div>

	<!-- SCREENSHIFT -->
<div id='div-gpt-ad-screenshift'>
<script type='text/javascript'>
jQuery(window).load(function() { // These functions get called when everything has loaded
	if (!loggedin) {
    //console.log('========== BNI v10b not logged in ==========');
    googletag.cmd.push(function() { googletag.display('div-gpt-ad-screenshift'); });
  } else { 
    console.log('========== BNI v10b logged in ==========');
  }
});
</script>
</div>
 <div class="clearfix"></div>
<div class="ad">
</div>
		<div class="ad">
			<!-- ROS_728x90_Bottom -->		</div>
					</div>
					<div id="footer" class="clearfix">
						<div id="footSections" class="col">
							
							<h4>Sections</h4>
							<ol class="siteMap">
								<li><a href="https://salisburypost.com" rel="bookmark"><span>Home</span></a></li>
								<li><a href="https://salisburypost.com/category/news/"  title="" rel="bookmark"><span>News</span></a></li>
								<li><a href="https://salisburypost.com/category/sports/" title="" rel="bookmark"><span>Sports</span></a></li>
								<li><a href="https://salisburypost.com/category/opinion/" title="" rel="bookmark"><span>Opinion</span></a></li>
								<li><a href="https://salisburypost.com/category/lifestyle/" title="" rel="bookmark"><span>Lifestyle</span></a></li>
								<li><a href="https://salisburypost.com/category/health/" title="" rel="bookmark"><span>Health</span></a></li>
								<li><a href="https://salisburypost.com/category/faith/" title="" rel="bookmark"><span>Faith</span></a></li>
								<li><a href="http://www.legacy.com/obituaries/salisburypost/" title="" rel="bookmark"><span>Obituaries</span></a></li>
								<li><a href="http://marketplace.salisburypost.com/adhunter/SalisburyPost/" title="" rel="bookmark"><span>Classifieds</span></a></li>
								<li><a href="http://video.salisburypost.com/" title="" rel="bookmark"><span>Video</span></a></li>
							</ol>
						</div>


						<div id="footServices" class="col">
							
							<h4>Services</h4>
							<ol class="siteMap">
								<li><a href="https://salisburypost.com/services/about-us/" title="" rel="bookmark">About Us</a></li>
								<li><a href="https://salisburypost.com/customer-service/" title="" rel="bookmark">Contact Us</a></li>
								<li><a href="http://www.salisburypost.com/subscriptions/" title="" rel="nofollow">Subscribe</a></li>
								<li><a href="https://salisburypost.com/services/policies/" title="" rel="bookmark">Policies</a></li>
								<li><a href="https://salisburypost.com/services/policies/" title="" rel="nofollow">Terms of use</a></li>
								<li><a href="https://salisburypost.com/services/submit-a-news-tip/" title="" rel="nofollow">Submit a news tip</a></li>
								<li><a href="https://salisburypost.com/customer-service/" title="" rel="nofollow">Online Forms</a></li>
								<li><a href="https://salisburypost.com/editorial-social/" title="" rel="nofollow">Social Media</a></li>
								<li><a href="http://salisburypostnie.com/" title="" rel="nofollow">NIE - Newspapers In Education</a></li>
								<li><a href="http://salisburypost.mycapture.com/mycapture/index.asp" title="" rel="bookmark"><span>Purchase Photos</span></a></li>
				
								
															</ol>
						</div>


						<div id="footCopyright" class="col">
														<h4>Copyright</h4>
							<ol>
								<li>&copy; 2021, Salisbury Post</li>
							</ol>
						</div>

					</div>
				</div>


				        <script src="https://www.salisburypost.com/wp-content/themes/2016-bni/media/js/vendor/jquery.bxslider/jquery.bxslider.min.js"></script>
        <script src="https://www.salisburypost.com/wp-content/themes/2016-bni/media/js/vendor/jquery.contentcarousel.js?1605287318"></script>
        <script src="https://www.salisburypost.com/wp-content/themes/2016-bni/media/js/vendor/jquery.easing.1.3.js"></script>
				<script src="https://www.salisburypost.com/wp-content/themes/2016-bni/media/js/vendor/jquery.timeago.js"></script>
        <script src="https://www.salisburypost.com/wp-content/themes/2016-bni/media/js/plugins.js?1592988658"></script>
        <script src="https://www.salisburypost.com/wp-content/themes/2016-bni/media/js/main.js?1603400489"></script>

        
				
<script type="text/javascript">tb_pathToImage = "https://www.salisburypost.com/wp-includes/js/thickbox/loadingAnimation.gif";tb_closeImage = "https://www.salisburypost.com/wp-includes/js/thickbox/tb-close.png";</script>
<script id='thickbox-js-extra'>
var thickboxL10n = {"next":"Next >","prev":"< Prev","image":"Image","of":"of","close":"Close","noiframes":"This feature requires inline frames. You have iframes disabled or your browser does not support them.","loadingAnimation":"https:\/\/salisburypost.com\/wp-includes\/js\/thickbox\/loadingAnimation.gif"};
</script>
<script type='text/javascript' src='https://salisburypost.com/wp-includes/js/thickbox/thickbox.js?m=1615321596g'></script>
<script src='https://www.salisburypost.com/wp-content/plugins/metronet-profile-picture/js/mpp-frontend.js?ver=2.3.6' id='mpp_gutenberg_tabs-js'></script>
<script type='text/javascript' src='https://salisburypost.com/wp-includes/js/hoverintent-js.min.js?m=1615321596g'></script>
<script src='https://salisburypost.com/wp-includes/js/admin-bar.min.js?ver=5.7' id='admin-bar-js'></script>
<script id='admin-bar-js-after'>
jQuery(document).ready( function($) {
	$('#wp-admin-bar-my-sites-search.hide-if-no-js').show();
	$('#wp-admin-bar-my-sites-search input').keyup( function( ) {
		var searchValRegex = new RegExp( $(this).val(), 'i');
		$('#wp-admin-bar-my-sites-list > li.menupop').hide().filter(function() {
			return searchValRegex.test( $(this).find('> a').text() );
		}).show();
	});
});
</script>
<script id='wp-polls-js-extra'>
var pollsL10n = {"ajax_url":"https:\/\/salisburypost.com\/wp-admin\/admin-ajax.php","text_wait":"Your last request is still being processed. Please wait a while ...","text_valid":"Please choose a valid poll answer.","text_multiple":"Maximum number of choices allowed: ","show_loading":"1","show_fading":"1"};
</script>
<script src='https://www.salisburypost.com/wp-content/plugins/wp-polls/polls-js.js?ver=2.75.3' id='wp-polls-js'></script>
<script type='text/javascript' src='https://salisburypost.com/wp-includes/js/wp-embed.min.js?m=1615321596g'></script>
<script src='https://stats.wp.com/e-202114.js' defer></script>
<script>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:9.6',blog:'170543381',post:'503395',tz:'-4',srv:'salisburypost.com'} ]);
	_stq.push([ 'clickTrackerInit', '170543381', '503395' ]);
</script>
				</div><!-- END undertone -->
            </body>
</html>